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What is MassHunter Personal Compound Database and Library 
Manager?

The MassHunter Personal Compound Database and Library Manager lets you edit, 
search, and create personal compound databases (PCDs) and personal compound 
databases and libraries (PCDLs). The MassHunter PCDL Manager lets you search 
and store MS/MS centroid spectra acquired on a Q-TOF instrument. It also lets you 
import spectral information from a .CEF file or copy-and-paste spectra from 
MassHunter Qualitative Analysis and search for those spectra in the current 
PCDL. 

A PCDL contains both an accurate mass compound database and an MS/MS 
accurate mass spectral database, which is often referred to as a spectral library or 
library. A PCD is an accurate mass retention time database.

MassHunter PCDL Manager lets you:

• Search or browse MS/MS spectra in PCDLs.

• Search for compounds in both PCDs and PCDLs, using text, formula, accurate 
mass, and retention time (optional or required). The use of retention time 
increases the compound identification specificity.

• Create and edit custom PCDs and PCDLs, including adding proprietary 
compounds, retention times, and MS/MS spectra.

• Import mass lists from Agilent MassHunter Mass Profiler, GeneSpring MS, and 
Qualitative Analysis software.

• Load spectra from either a .CEF file or by copy-and-pasting mass spectra from 
MassHunter Qualitative Analysis software.

• Do private, on-site searches, which keep intellectual property safe.

• Link to websites for more information on many compounds.

MassHunter PCDL Manager also lets you do automated or manual searches from 
MassHunter Qualitative Analysis software as described on page 16.

Compound names Many compounds are commonly known as their salts. The mass spectrometer, 
however, detects the anion or cation portion of the salt, rather than the neutral 
salt. PCD and PCDL entries contain the familiar compound names, but the 
empirical formulae reflect the interesting (cation or anion) portion of the molecule 
rather than the formula of the neutral compound salt. For example, the full name 
Vecuronium bromide is used for identification in the PCDL, even though the 
mass/formula only includes the Vecuronium part of the compound.
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Installation

If the MassHunter Personal Compound Database and Library Manager is not 
already installed on your system, install it as follows.
1 Insert the MassHunter Personal Compound Database and Library Manager disk 

into the disk drive.
2 Click the Windows Start button and select Run.
3 Type x:\setup, where x is the letter of the disk drive, and click OK.
4 Follow the instructions on the screen.

The MassHunter PCDL Manager is installed, along with the following .cdb files:

• PCDL\ForensicsTox_AM_PCDL.cdb - Forensic Toxicology master PCDL

• PCDL\Sulfas_AM_PCDL.cdb - a small example master PCDL.

• PCDL\Empty_PCDL.cdb - an empty master PCDL, which can be used to create a 
custom PCDL for importing compounds. To create a PCDL and import 
compounds, see “To create a custom PCDL” on page 14 and “To import 
compounds to a custom PCDL” on page 14. 

To remove MassHunter PCDL Manager

Use the Add/Remove window of the Control Panel.

Doing this removes the PCDL Manager and master PCDs and PCDLs that have 
been installed, but does not remove custom PCDs and PCDLs you have created.

Startup

1 Select Programs > Agilent > MassHunter Workstation > Personal Compound 
Database and Library from the Windows Start menu to start the MassHunter 
PCDL Manager.
The PCDL that was last used is displayed as the default PCDL to open when you 
start the MassHunter PCDL Manager.

2 To open a different PCDL, see “To open a PCDL” on page 12.
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Main Window

The PCDL Manager main window has the following areas and controls.

• “Toolbar”(below)

• “Menus” on page 5

• “Compound Tabs” on page 8

• “Spectral Tabs” on page 10

Toolbar

The following items are available on the MassHunter PCDL Manager toolbar:

Button Equivalent Menu Item Comments

Database/Library > Find 
Compounds

Available only when the Single Search or 
Batch Search tabs are displayed.  
Same as pressing the F5 key. 

Database/Library > Find Spectra Available only when the Spectral Search or 
Browse Spectra tabs are displayed.  
Same as pressing the F5 key.

File > Print Results

File > Export Results For use with Batch Summary Results only.

File > New Database/Library

File > Open Database/Library

Help > Contents
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Menus

The following menus are available in MassHunter PCDL Manager:

File menu

New Database/Library Lets you create a custom PCDL that can be edited and 
personalized for your lab. This is done by creating a copy of an existing PCDL with 
a new name that can be edited. See “To create a custom PCDL” on page 14.

Open Database/Library Lets you open a different PCDL.

Backup Database/Library Lets you copy the PCDL for archive purposes.

Import Compounds  Lets you select a file that contains compounds to add to a 
custom PCDL if editing is enabled. If you start with an empty PCDL, then you are 
essentially creating a custom PCDL from the imported compounds.

Export Results Lets you export batch summary results for use with other 
programs, such as spreadsheets and word processors.

Print Results  Lets you print search results and structures.

Exit Closes the MassHunter PCDL Manager window.

Edit menu 

These menu items are for use with custom PCDs and PCDLs with editing enabled 
only and are only available when the Edit Compounds tab is displayed.

Add New Compound Creates a new compound in the PCDL. It has a mass of 0 
and is named “New Compound”. The new compound is displayed at the end of the 
Results table. Enter information such as RT, Formula, Name, and Structure for the 
new compound in the Edit Compounds tab.

Save As New Compound Creates a new compound in the PCDL using the current 
values of the edit fields on the Edit Compounds tab. The new compound is 
displayed at the end of the Results table.

Update Selected Compound Updates the information for the selected compound 
in the PCDL. The updated information is reflected in the Results table.
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Delete Selected Compound Removes the selected lines of the Results table, which 
removes the selected compounds from the PCDL. Use Ctrl+click or Shift+click to 
select multiple lines.

View menu

Add/Remove Compound Columns Opens the Add/Remove Columns dialog box, 
which lets you specify what information is displayed in the Compound Results 
table.

Restore Default Compound Columns Displays the columns in the Compound 
Results table as they were originally set in the software.

Structure Details Opens the Structure Details dialog box, which displays the 
current structure in a larger size for easier viewing.

Database/Library menu 

Find Compounds Searches the PCDL for compounds that match criteria specified 
on the Single Search tab or Batch Search tab. Only available when either the Single 
Search tab or Batch Search tab is displayed.

Find Spectra Searches the PCDL for spectra that match criteria specified on the 
Spectral Search tab or Browse Spectra tab. Only available when either the Spectral 
Search tab or Browse Spectra tab is displayed.

Allow Editing A toggle that enables or disables editing operations to a custom 
PCDL. A master PCDL cannot be edited.

Database/Library Information Lets you view information about the current PCDL 
and edit the description for custom PCDs or PCDLs with editing enabled.
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Links menu 

Lets you access websites for information on compounds or metabolites. The links 
displayed depend on the type of the current PCDL as follows:

Links for a General PCDL

• PubChem (National Center for Biotechnology Information)
• ChemSpider (structure-based chemistry information)

Links for a Metabolomics PCD or PCDL

• Agilent Metabolomics

• Agilent Metabolomics Lab

• PubChem (National Center for Biotechnology Information)

• ChemSpider

• METLIN (Scripps Center for Mass Spectrometry)

• KEGG (Kyoto Encyclopedia of Genes and Genomes)

• HMP (Human Metabolome database)

• Lipid MAPS (LIPID Metabolites And Pathways Strategy)

Links for a Forensics PCD or PCDL

• PubChem (National Center for Biotechnology Information)

• ChemSpider

• Chem Industry

• TOXNET

• ChemBioFinder

• NIST Chemistry WebBook

• IPCS INTOX Databank

• SOFT

• TIAFT

• AAFS

• Related Forensics Websites
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Links for a Pesticides PCD or PCDL

• PubChem (National Center for Biotechnology Information) 

• ChemSpider

• Chem Industry 

• Compendium of Pesticides 

• EPA - Pesticides (Environmental Protection Agency) 

• NPIC (National Pesticide Information Center) 

• NIH NLM (National Institute of Health - National Library of Medicine) 

• TOXNET 

• PAN Database 

• WHO - Pesticides (World Health Organization) 

Help menu

Contents, Index, and Search Opens the online Help window for MassHunter 
PCDL Manager, with the appropriate tab displayed.

View EULA Displays the license agreement for MassHunter PCDL Manager in a 
Notepad window.

About Displays the version and build number of the MassHunter PCDL Manager.

Compound Tabs

The following tabs are available for searching, viewing, and editing compounds:

Single Search tab

Lets you search for compounds in the PCDL. Search results are displayed in the 
Compound Results table in the lower part of the window. See “To find compounds” 
on page 17.

Batch Search tab

Lets you search for compounds in the PCDL by specifying a mass list and optional 
retention times. Search results are displayed in the Compound Results table in the 
lower part of the window. See “To find compounds from a mass list” on page 21.
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Batch Summary tab

Shows a summary view of all Best fit hits from a Batch Search. Results can be 
exported for use with other applications. You can also add comments and update 
retention times for custom PCDs or PCDLs with editing enabled. See “To view 
batch summary results” on page 24.

Edit Compounds tab

For custom PCDs or PCDLs that allow editing, you can use this tab to edit 
information for compounds and to add new compounds. Before editing existing 
compounds, do a Single or Batch search, so that the compounds to be modified are 
present in the Compound Results table. See “To edit compounds in a custom 
PCDL” on page 27.

Compound Results

Compound search results are displayed in the lower part of several tabs in the 
MassHunter PCDL Manager window. The way the results are displayed can be 
changed as described in “To change how data is displayed in results tables” on 
page 19.

Clicking on a row of the table displays structure information about that compound 
in the Structures area, if the structure is available in the PCDL.

You can also select compounds in the results table for editing on the Edit 
Compounds and Edit Spectra tabs (custom PCDs or PCDLs with editing enabled 
only). See “To edit compounds in a custom PCDL” on page 27.

Structures 

Structure tab  This area on the right side of compound-related tabs displays 
structure information for the compound currently selected in the Compound 
Results table, if it is available in the PCDL. Clicking the  button opens the 
Structure Details dialog box and displays a larger image of the structure.

MOL Text tab  Displays the text version of the structure. If the current PCDL is a 
custom PCDL with editing enabled, you can copy text from a molecular drawing 
tool that is capable of generating MOL file text and paste it into this area to update 
the structure of the selected compound. Or you can use the  button in the 
Structure area to load a structure from a .MOL file.
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Spectral Tabs

The following tabs are available for searching, viewing, and editing spectra:

Spectral Search Tab

Lets you load spectra from a .CEF file or copy-and-paste spectra from Qualitative 
Analysis and search for the spectra in the current PCDL. 

Browse Spectra Tab

Lets you search the current PCDL for spectra that match certain parameters, such 
as mass, collision energy, ion polarity, and ionization mode. Use the default search 
parameters to view all spectra in the PCDL. 

You can also view spectral information for compounds retrieved from the Single 
Search tab or Batch Search tab by clicking on the compound of interest in the 
compound results table in the lower part of the tab.

Spectral results are displayed in the Spectral Information Table in the middle part 
of the tab.

Edit Spectra Tab

You can use this tab to add, delete, and edit spectra in a custom PCDL, if editing is 
enabled for the PCDL. Before editing, you must do a Single or Batch search, so that 
some compounds are present in the compound results table in the lower part of 
the tab.

Spectral Plot Window

This area of the spectra-related tabs lets you view selected spectra in graphic 
format and as a list of masses and relative abundances.
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Getting Started

The following topics will help you get started with Agilent MassHunter PCDL 
Manager. This guide and the online Help explain these activities.

• “PCDL operations” on page 12

• “Searching a PCDL in Qualitative Analysis” on page 16

• “Searching a PCDL in MassHunter PCDL Manager” on page 17

• “Doing a batch search” on page 21

• “Editing a custom PCDL” on page 26

• “Spectral searching and editing” on page 29
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PCDL operations

The following PCDL operations are described in the following pages:

• “To open a PCDL” on page 12

• “To back up a PCDL” on page 13

• “To view PCDL information” on page 13

• “To create a custom PCDL” on page 14

• “To import compounds to a custom PCDL” on page 14

To open a PCDL

The PCDL that was last used is displayed as the default PCDL to open when you 
start MassHunter PCDL Manager. Use this procedure to open a different PCDL.
1 Open the Open Database/Library dialog box in either of the following ways:

• Select Open Database/Library from the File menu. 

• Click the  button on the toolbar.
2 Select the file of interest (.cdb extension) and click the Open button.

NOTE Master PCDs and PCDLs cannot be edited, but they can be used to create custom PCDs or 
PCDLs that can be edited. See “To create a custom PCDL” on page 14.
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To back up a PCDL

1 Select Backup Database/Library from the File menu. 
2 Select a folder for the backup file or accept the default folder, which is: 

MassHunter\PCDL\Archive 

3 Type in a file name for the backup file or accept the default file name, which is 
in the form: 
<dbname>.<yyyy.mm.dd>.cdb 

where dbname is the name of the current PCDL, yyyy is the current year, mm is 
the current month, and dd is the current day of the month. 

4 Click the Save button. A backup copy of the PCDL is created using the specified 
file name and location.

To view PCDL information

1 Select Database/Library Information from the Database/Library menu. 
2 View the following information about the PCDL: 

• File name

• # Compounds (entries) in the PCDL

• Master or User

• Type: General, Metabolomics, Pesticides, or Forensics

• Edit allowed (Yes or No)

• Last modified timestamp

• Version number

• Description - the description can be edited if the current PCDL is a custom
PCDL with editing enabled.

3 Click the Apply button if you modified the Description or changed the database 
Type (General, Metabolomics, Pesticides, or Forensics).

4 Click the Close button to close the Database/Library Information dialog box.
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To create a custom PCDL

1 Select New Database/Library from the File menu or click the  button on 
the toolbar.

2 Do the following steps on the New Database/Library dialog box: 

a Select a starting PCDL for the new PCDL. The default path is \PCDL.

b Select the PCDL type for the new PCDL from the following choices: General, 
Metabolomics, Pesticides, or Forensics.

c Type in a name for the new PCDL file. 

d Enter a description for the new PCDL. 

e Click the Create button to create the new PCDL. 
The new PCDL becomes the current working PCDL and is automatically 
enabled for editing. 

To import compounds to a custom PCDL

Use the following procedure to import compounds into a custom PCDL or to create 
a custom PCDL from a compound list created by another application. If you start 
with an empty PCDL, then you are essentially creating a custom PCDL from the 
imported compounds.
1 Prepare the import file. The format required for the import file is described in 

the online Help. The .CSV or .TXT file can be created in any of the following ways:

• Exported from MassHunter PCDL Manager as described in “To export batch
summary results” on page 25.

• Exported from another application such as Agilent Mass Profiler or
GeneSpring MS software.

• Manually in Excel.
2 Open the custom PCDL of interest or create a new PCDL as described in “To 

create a custom PCDL” on page 14.
3 Marking Allow Editing on the Database/Library menu to enable editing on this 

PCDL.
4 Select Import Compounds from the File menu.
5 Select the .CSV or .TXT file prepared in Step 1 that contains the compounds of 

interest, then click the Open button.
6 To view the new compounds in the PCDL, do a search on the Single Search tab 

with no criteria or criteria that you know will find the compounds of interest. 
The compounds will be listed in the Compound Results table in the lower part 
of the window. 
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7 Compounds that were not imported due to problems with the input file are 
saved in the file <ImportFileName>-ImportLog.csv, where <ImportFileName> is the 
name of the import file selected in Step 5. Edit this log file to fix the problems, 
then import the corrected file. 

8 (Optional) See “To edit compounds in a custom PCDL” on page 27 if you want 
to change information for the imported compounds. 

NOTE The mass is calculated from the formula, unless the difference is > 0.0001 Da. In that case, 
the Mass and Formula values will be as read from the input file, and those compounds will 
be added to the log file described in Step 7. The information in the log file can be used to 
determine the correct Formula or Mass. Errors can occur when 1) the mass value was the 
mass from the spectrum and not a neutral mass, or 2) the formula contained the adduct 
(such as Cl).
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Searching a PCDL in Qualitative Analysis

Use the following procedures to search a PCDL with MassHunter Workstation 
Software–Qualitative Analysis program. These steps apply to version B.03.01 of 
Qualitative Analysis and may be slightly different in later revisions.

To use a PCDL to identify compounds in Qualitative Analysis

Use this procedure to identify compounds with a PCDL:
1 Open the data file of interest in Qualitative Analysis.
2 Find compounds as described in Qualitative Analysis online Help.
3 Select the compounds to search in the Compound List window or Data 

Navigator.
4 Set the search criteria in the Identify Compounds > Search Database section 

of Method Editor:

a On the Search Criteria tab, select Mass as the Values to match option.

b On the Database tab, click the Browse […] button to open the Open Database 
File dialog box.

• Select File Type .cdb to see a list of PCDLs.

• Select the PCDL of interest.
5 Initiate the search and review the results in the DB Search Results window.

To use a PCDL to identify spectrum peaks in Qualitative Analysis

Use this procedure to identify spectrum peaks with a PCDL:
1 Open the data file of interest in Qualitative Analysis.
2 Extract a mass spectrum or extract a peak spectrum as described in Qualitative 

Analysis online Help.
3 If not already set, set the search criteria in the Identify Compounds > Search 

Database section of Method Editor as described in Step 4 above.
4 Initiate the search by right-clicking on the spectrum and selecting Search 

Database for Spectrum Peaks from the shortcut menu (or in other ways 
described in Qualitative Analysis online Help).
The PCDL is searched for the masses in the spectrum. If hits are found, 
information such as masses, formulas, and compound names is displayed in the 
DB Search Results window. 

5 Review the results in the DB Search Results window.
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Searching a PCDL in MassHunter PCDL Manager

Searching a compound PCDL for compounds matching certain criteria can be 
broken into the following activities, which are described in the following pages:

• “To find compounds” (below)

• “To view compound search results” on page 19

• “To change how data is displayed in results tables” on page 19

• “To print compound results” on page 20

To find compounds

1 If the PCDL you want to search is not already open, open it in either of the 
following ways:

• Select Open Database/Library from the File menu, or 

• Click the  button on the toolbar.
2 Click on the Single Search tab.
3 To return the contents of the entire PCDL, leave the search fields blank and skip 

to Step 6. Otherwise, set the desired mass search criteria:

a Mass and Mass tolerance in ppm or mDa

b Type of mass ([M+H]+, Neutral, or [M-H]-)

• Select [M+H]+ mass type if you are searching for an observed positive ion in 
the PCDL. The neutral mass value will be automatically calculated, assuming 
the ion was a positive protonated ion.  
 
If Include cations is selected in Step 3c, the neutral mass of a cation is 
calculated. Only those compounds that have been defined as cations in the 
PCDL will be compared to the calculated neutral mass of a cation.

• Select Neutral if the mass is the calculated neutral mass value, usually a 
value that was calculated by Molecular Feature Extraction (MFE) software. 
Do not select this value for a mass observed in a spectrum. Ions observed in 
a spectrum have a charge and need to be converted to neutral to work with 
the PCDL. For observed ions use either the [M+H]+ or [M-H]- selection.  
 
If Neutral is selected, you can choose Include anions or Include cations for 
the Ion search mode setting in Step 3c.
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• Select [M-H]- mass type if you are searching for an observed negative ion in 
the PCDL. The neutral mass value will be automatically calculated, assuming 
the ion was a negative deprotonated ion.  
 
If Include anions is selected in Step 3c, the neutral mass of an anion is 
calculated. Only those compounds that have been defined as anions in the 
PCDL will be compared to the calculated neutral mass of an anion.

c Ion search mode:

• Include neutrals is normally always selected. Clear it if you want to search 
ions only.

• If you selected Neutral for the mass type in Step 3b, then select Include 
anions or Include cations if you also want to consider those chemicals that 
don't pick up or lose a proton to ionize. Searching both modes will return 
false matches. 

• Choose Include anions if the data was acquired in negative ion mode.

• Choose Include cations if the data was acquired in positive ion mode. 
4 When searching a master PCDL or a custom PCDL without retention time data, 

be sure to clear the Require checkbox for Retention time. When searching a 
PCDL that contains retention time information for compounds, enter a 
retention time and RT tolerance if you want to consider retention times in the 
search.

5 If desired, enter a Formula, Name, CAS ID, or ChemSpider ID to find 
compounds based on these fields. You can also enter text in the Notes field to 
search for a text string, such as “antidiabetic”.
The following additional search fields are available for Metabolomics PCDs or 
PCDLs only: METLIN, KEGG, HMP, and LMP IDs.

6 Initiate the search in any of the following ways: 

• Click the Find Compounds button on the toolbar, 

• Select Find Compounds from the Database menu, or 

• Press the F5 key. 
7 View search results in the Compound Results table at the bottom of the window. 

For more information, see “To view compound search results” on page 19 and 
“To change how data is displayed in results tables” on page 19.
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To view compound search results

1 Do a search on the Single Search tab as described in “To find compounds” on 
page 17.

2 View search results in the Compound Results table at the bottom of the window. 
You can change how compound results are displayed as described in “To change 
how data is displayed in results tables” on page 19.

3 Click on a compound in the Results table to view its structure information in 
the Structures area on the right side of the window, if the structure is available 
in the PCDL.

4 Click on the Edit Compounds tab to edit information for custom PCDs or 
PCDLs that allow editing, as described in “To edit compounds in a custom 
PCDL” on page 27.

5 To print results, see “To print compound results” on page 20.
6 If any of the compound results contain mass spectra, you can view them as 

described in “To view spectra for a compound” on page 31.

To change how data is displayed in results tables

1 To sort the table by the entries in a column, click the heading for the column of 
interest.

2 To change the order of the columns of information in the table, drag a column 
heading to a different position. Repeat this until the desired order is achieved.

3 To resize a column to fit the information contained in it, double-click on the 
right column divider in the heading of the column of interest.

4 To resize a column to a specific width, drag the separator between the column 
headings to the right or left until the column is the desired width.

5 To change which columns of information are displayed in the table:

a Right-click in the table and select Add/Remove Columns from the shortcut 
menu to open the Add/Remove Columns dialog box.

b Move the items of information that you want to display from the Available 
columns list to the Show these columns list using the Add -> button or by 
double-clicking on them.

c Remove any unwanted items of information from the Show these columns 
list using the <- Remove button or by double-clicking on them.

d Click OK.
The results table will be updated to reflect the selected columns of information.
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To print compound results

Results can be printed from the Single Search, Batch Search, Batch Summary, and 
Edit Compounds tabs.
1 If you want to print only certain compounds, highlight those rows in the 

Compound Results table using Ctrl+click or Shift+click.
2 Open the Print Results dialog box in any of the following ways:

• Select Print Results from the File menu.

• Click the  button on the toolbar.

• Right-click in the results table and select Print Results from the shortcut 
menu.

3 Select desired report options from the following:

• Printer (destination)

• Print Preview if you want to view the report on the screen first.

• Fit to page to size the report to fit the width of the page.

• Orientation (Landscape or Portrait). The default is Landscape, as it allows 
more columns of information.

4 Select the desired report content options from the following: 

• All rows or Only highlighted rows of the results table 

• Include search parameters 

• Include unmatched masses 

• Print structures and the size (240 x 160, 360 x 240, or 540 x 360)
5 Click OK to generate the report. 

If you selected Print Preview in Step 3, review the report in the Print preview 
pane. Click the  button on the toolbar to print the report. 

NOTE For Single Search, only the first 30 compound results will be printed.
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Doing a batch search

Searching a PCDL for compounds based on a mass list can be broken into the 
following activities, which are described in the following pages:

• “To find compounds from a mass list” (below)

• “To view batch search results” on page 23

• “To view batch summary results” on page 24

• “To export batch summary results” on page 25

To find compounds from a mass list

1 If the PCDL you want to search is not already open, open it in either of the 
following ways:

• Select Open Database/Library from the File menu.

• Click the  button on the toolbar.
2 Click on the Batch Search tab.
3 Enter a mass list in one of the following ways: 

• Click the File button to the left of the mass list table to open a mass list file 
output by MassHunter Qualitative Analysis (.csv or .txt file), Mass Profiler 
(.xls file), or GeneSpring MS (.txt file).

• Copy and paste a compound list from MassHunter Qualitative Analysis.

• Type masses and retention times directly into the table.
4 Select or enter the Type of mass (normally Neutral for Batch Search) and Mass 

tolerance, in ppm or mDa. 
5 Select Ion search mode options as follows: 

• Include neutrals is normally always selected.

• Select Include anions and/or Include cations if you also want to consider 
those few chemicals that don't pick up or lose a proton to ionize. 

6 Select one of the following options for Retention times:

Option Meaning Application

Ignore Don’t consider retention time even 
if it is present in the list

When searching the sample master PCDL 
or any custom PCDL without retention time 
data.
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7 Initiate the search in any of the following ways: 

• Click the Find Compounds button on the toolbar.

• Select Find Compounds from the Database/Library menu.

• Press the F5 key. 
8 When the search is complete, the number of hits for each mass appears in the 

Hits column of the mass list, and the list is automatically sorted to show the 
masses with the most hits at the top of the list. To sort the list by a different 
criterion, click the heading for the column of interest (Mass or RT). 
Masses with conflicting hits are shown in red text in the Mass List table.

9 Click on a row in the Mass List table to display the compounds found for that 
mass in the Compound Results table in the lower part of the window. For more 
information on viewing batch search results, see “To view batch search results” 
on page 23. 

10 Select and view the best compound hit for each mass as described in “To view 
batch summary results” on page 24.

Optional Use retention time information to 
rank a compound higher if its 
retention time matches with the 
observed retention time.

When searching a PCDL that contains 
retention time information for some 
compounds.

Required Consider only compounds that 
match the specified retention time 
range.

When searching a PCDL that contains 
retention times for some compounds and 
both mass and RT criteria must be met.
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To view batch search results

1 Do a search on the Batch Search tab as described in “To find compounds from a 
mass list” on page 21.

2 When the search is complete, the number of hits for each mass appears in the 
Hits column of the mass list, and the list is automatically sorted to show the 
masses with the most hits at the top of the list. To sort the list by a different 
criterion, click the heading for the column of interest (Mass or RT). Masses with 
conflicting hits are shown in red text in the Mass List table.

3 Click on a row in the Mass List table to display the compounds found for that 
mass in the Search Results table in the lower part of the window. 

 Tip For ease of reviewing results, use the F4 key to scroll down the Mass List and the 
Shift+F4 keys to scroll back up. The information in the Results table will be updated 
as you scroll through the mass list. 
4 (Optional) Change how the batch search results are displayed as described in 

“To change how data is displayed in results tables” on page 19. 
5 See “To view batch summary results” on page 24 for information on selecting 

and viewing the best compound hit for each mass.
6 Click on a compound in the Compound Results table to view its structure 

information in the Structures area on the right side of the window, if the 
structure is available in the PCDL. 

7 Click on the Edit Compounds tab to edit information for custom PCDs or 
PCDLs that allow editing, as described in “To edit compounds in a custom 
PCDL” on page 27.

8 To print batch results, see “To print compound results” on page 20.
9 If any of the compound results contain mass spectra, you can view them as 

described in “To view spectra for a compound” on page 31.
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To view batch summary results

1 Do a search on the Batch Search tab as described in “To find compounds from a 
mass list” on page 21.

2 Click on a row in the Mass List table to display the compounds found for that 
mass in the Batch Search Results table in the lower part of the window. Masses 
with conflicting hits are shown in red text in the Mass List table.

3 Review the entries marked in the Best column for each mass and if necessary, 
edit the Batch Search Results table to select the best compound hit by marking 
the desired row (compound). You can also clear the box for the selected hit to 
ignore all the results for that compound.

4 Click the Batch Summary tab to view only the best hits from the Batch Search 
Results table. Compounds with conflicting mass hits are shown in red text in 
the results table.

5 (Optional) Change how the batch summary results are displayed as described 
in “To change how data is displayed in results tables” on page 19. 

6 Click on a compound in the results table to view its structure information in the 
Structures area on the right side of the window, if the structure is available in 
the PCDL. 

7 Click on the Edit Compounds tab to edit information for custom PCDs or 
PCDLs that allow editing, as described in “To edit compounds in a custom 
PCDL” on page 27.

8 To export batch summary results, see “To export batch summary results” on 
page 25.

9 To print batch summary results, see “To print compound results” on page 20.
10 (Optional) For a custom PCDL with editing enabled, you can update retention 

times in the PCDL for the compounds shown in the Batch Summary Results 
table. See “To update retention time data” on page 26.
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To export batch summary results

1 Do a batch search as described in “To find compounds from a mass list” on 
page 21.

2 Select and view the best compound hit for each mass as described in “To view 
batch summary results” on page 24, or clear the box for the selected hit to 
ignore all the results for that compound.

3 (Optional) Change the display of data in the Batch Summary tab as described 
in “To change how data is displayed in results tables” on page 19. 

4 Open the Export Results dialog box in any of the following ways: 

• Select Export Results from the File menu.

• Click the  button on the toolbar.

• Right-click in the results table and select Export Results from the shortcut 
menu in the Batch Summary results table.

5 Click the Select button if you wish to specify a different file name, location, or 
file type for the export file. Otherwise the following default file name, location, 
and format is used: 

• If the mass list was opened from a file, the export file name is: 
<massListFileName>-<timestampInSecs>.txt

• If you entered the mass list manually, the export file name is:  
MassList-<timestampInSecs>.txt

• The default location for the export file is MassHunter\PCDL\Results. 

• The default output file format is .TXT (tab-separated values), but you can 
select .CSV (comma-separated values) instead.

6 Select one or more of the following types of information to include in the report: 
Search parameters, Results, and Unmatched masses (available only if the 
Results checkbox is marked).

7 Mark the Open results file after exporting option to open the batch summary 
results file automatically in the associated application. 

8 Click OK to output the results. 
9 The results will open in the associated application such as Excel if you selected 

the Open results file option in Step 7. Otherwise open the exported results file 
in your application of choice at a later time.

NOTE When a .csv file is opened in Excel, the Text Import Wizard may be displayed automatically. 
If so, follow the prompts to specify the proper delimiter for your file, e.g. comma or tab. 

If the wizard is not displayed automatically, all the values for each row may appear in the 
first column. To split the text into columns, select the first column (A), then start the wizard 
by selecting Text to Columns on the Data tab, in the Data Tools group.
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Editing a custom PCDL

Compound information in a custom PCDL can be edited in the following ways:

• “To update retention time data” on page 26

• “To edit compounds in a custom PCDL” on page 27

To update retention time data

This procedure applies to custom PCDs or PCDLs only.
1 Open the custom PCDL of interest. Be sure that editing is enabled by marking 

Allow Editing on the Database/Library menu.
2 Click on the Batch Search tab.
3 Enter a mass list in one of the following ways: 

• Click the File button to the left of the mass list table to open a mass list file 
output by MassHunter Workstation Qualitative Analysis (.csv or .txt file), 
Mass Profiler (.xls file), or GeneSpring MS (.txt file).

• Copy and paste a compound list from Qualitative Analysis.

• Type in masses and retention times directly into the table.

4 Select one of the following options for Retention times:

• Ignore - Use this option to search a PCDL with no retention time 
information or retention times that may be outside the tolerance window.

• Optional - Use this option to search a PCDL that either has no retention time 
information or has retention times missing for some compounds that you 
now want to update. 

• Required - Use this option if you only want to identify and update those 
compounds that already have retention time information in the PCDL. 
Specify an RT tolerance value in minutes as well.

5 Set other search criteria if desired as described in “To find compounds from a 
mass list” on page 21.

6 Initiate the search in any of the following ways: 

• Click the Find Compounds button on the toolbar.

• Select Find Compounds from the Database/Library menu.

• Press the F5 key.

NOTE Every mass in the mass list must have a retention time value for this procedure.
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7 When the search is complete, the number of hits for each mass appears in the 
Hits column of the mass list, and the list is automatically sorted to show the 
masses with the most hits at the top of the list. To sort the list by a different 
criterion, click the heading for the column of interest (Mass or RT). 
Masses with conflicting hits are shown in red text in the Mass List table. 

8 Click on a row in the Mass List table to display the compounds found for that 
mass in the Search Results table in the lower part of the window. For more 
information on viewing batch search results, see “To view batch search results” 
on page 23. 

9 Select and view the best compound hit for each mass as described in “To view 
batch summary results” on page 24 or clear the box for the selected hit to ignore 
that compound.

10 Click the Apply Retention Times button to apply retention times from the Mass 
List in the Batch Search tab for each of the compounds listed in the Batch 
Summary table.

To edit compounds in a custom PCDL

Use this procedure to edit information for compounds, to add a new compound, or 
to remove a compound.
1 Open the custom PCDL of interest. 
2 Enable editing by marking Allow Editing on the Database/Library menu.
3 Do a search using either of the following:

• “To find compounds” on page 17.

• “To find compounds from a mass list” on page 21.
4 When the search is complete, click the Edit Compounds tab.
5 To update information for a particular compound:

a Select the compound of interest by clicking on it in the Search Results table. 
Information for the selected compound is displayed in the Edit Compounds 
tab.

b Update information on the left side of the Edit Compounds tab, such as 
Name, Mass, RT, Formula, CAS or ChemSpider ID, and Ion type.

c Update structure information if desired in either of the following ways:

NOTE All conflicting results must be resolved before retention time data can be updated.
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• Click on the MOL Text tab and paste in MOL file text that you have copied 
from a molecular drawing tool (Ctrl+V), or 

• Click the  button in the Molecule area to open a .MOL file.

d Click the Update Selected button. The information for the compound is 
updated in the PCDL and the information you entered in Step 5b is reflected 
in the Results table.

6 To add a new compound to the PCDL:

a Click the Add New button. A new compound is created in the PCDL with a 
mass of 0 named “New Compound” and the new compound is displayed at 
the end of the Results table.

b Enter or change information for the new compound as described in Step 5 
above.

c Click the Update Selected button. The information you entered for the new 
compound is updated in the PCDL and the information is reflected in the 
Results table.

Alternate method 
to add a new 

compound

Enter information for a new compound on the left side of the Edit 
Compounds tab, such as Name, Mass, RT, Formula, CAS ID, and Ion type, then 
click the Save As New button. A new compound is created in the PCDL using 
the specified values. The new compound is displayed at the end of the Results 
table.

7 To remove a compound from the PCDL:

a Select the compound of interest by clicking on it in the Search Results table. 
Use Ctrl+click or Shift+click to select multiple compounds for deletion.

b Click the Delete Selected button.
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Spectral searching and editing

Searching and editing mass spectra in a PCDL is broken down into the following 
tasks:

• “To import spectra from a .CEF file” - below

• “To copy spectra from MassHunter Qualitative Analysis” - below

• “To paste spectra into MassHunter PCDL Manager” on page 30

• “To search a PCDL” on page 30

• “To browse spectra in the PCDL” on page 31

• “To view spectra for a compound” on page 31

• “To add, move, or remove spectra in a custom PCDL” on page 32

• “To clean up noisy spectra” on page 33

To import spectra from a .CEF file

Use this procedure to load spectra into MassHunter PCDL Manager that have been 
output to a .CEF file from another program such as MassHunter Qualitative 
Analysis software. 
1 Click to display the Spectral Search or Edit Spectra tab.
2 Click the Load Spectra button .
3 Select the .CEF file of interest and click the Open button.

If profile spectra or non-MS/MS spectra are contained in the file, a message is 
displayed saying that they have been skipped. Only centroided MS/MS spectra 
are loaded for use in MassHunter PCDL Manager.
The spectra appear in the Acquired spectra table. See the following topics for 
further use of imported spectra:

• “To search a PCDL” on page 30

• “To add, move, or remove spectra in a custom PCDL” on page 32

• “To clean up noisy spectra” on page 33

To copy spectra from MassHunter Qualitative Analysis

1 Open the data file of interest in MassHunter Qualitative Analysis software.
2 Run Find by Targeted MS/MS or Find by Auto MS/MS, depending on how the 

data was acquired.
3 Expand the compounds of interest in Data Navigator to see the spectral results.
4 Select the product ion spectra of interest.
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5 If the data was acquired in Profile mode, right-click and select Convert Profile 
to Centroid and Replace from the shortcut menu.

6 Right-click the MS Spectrum Results window and select Copy to Clipboard. 
All spectra displayed in the MS Spectrum Results window are copied, not just 
the highlighted ones.

To paste spectra into MassHunter PCDL Manager

1 Copy spectra from MassHunter Qualitative Analysis as described in “To copy 
spectra from MassHunter Qualitative Analysis” on page 29.

2 Click to display the Spectral Search or Edit Spectra tab.
3 Right-click in the Acquired spectra table and select Paste Spectra. 

If profile spectra or non-MS/MS spectra were copied from MassHunter 
Qualitative Analysis, a message is displayed saying that they have been skipped. 
Only centroided MS/MS spectra are pasted into MassHunter PCDL Manager. 
The spectra are listed in the Acquired spectra table.

To search a PCDL

1 If the PCDL you want to search is not already open, open it by clicking Open 
Database/Library from the File menu or the  button on the toolbar.

2 Import spectra as described in “To import spectra from a .CEF file” or “To copy 
spectra from MassHunter Qualitative Analysis” on the previous page.

3 Click to select the spectrum to search from the Acquired spectra table on the 
Spectral Search tab.

4 Use the default search parameters or set any of the following search 
parameters: Search type, Filters, or Tolerances. These parameters are 
described in online Help.

5 Click to start the search.
The search results are displayed in the Spectral Results table in the lower part 
of the tab. If desired, the spectral results display can be changed as described in 
To change how data is displayed in results tables.

6 Click on a row of the results table to view the mass spectrum plot for the 
selected compound in the Spectral Plot Window to the right of the table.

7 Click the Mass Lists tab in the Spectral Plot window to view a list of masses and 
abundance values for the selected compound.

NOTE Spectra cannot be pasted into the Library spectra table.
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To browse spectra in the PCDL

Use the following procedure to search the current PCDL for spectra that match 
certain parameters, such as mass, collision energy, ion polarity, and ionization 
mode.
1 Click the Browse Spectra tab.
2 Use the default search parameters to return the contents of the entire PCDL 

and skip to Step 3. Otherwise, set the desired search criteria: Mass, Collision 
energy, Ion polarity, and Ionization mode. These parameters are described in 
online Help.

3 Click to start the search.
The PCDL search results are displayed in the Spectral Results table in the 
middle of the tab. If desired, the spectral results display can be changed as 
described in “To change how data is displayed in results tables” on page 19.

4 Click on a row of the results table to view the mass spectrum plot for the 
selected spectrum in the Spectral Plot Window to the right of the table.

5 Click the Mass Lists tab in the Spectral Plot window to view a list of masses and 
abundance values for the selected spectrum.

To view spectra for a compound

1 Do a compound search using either of the following:

• “To find compounds” on page 17.

• “To find compounds from a mass list” on page 21.
2 When the compound search is complete, click the Browse Spectra tab.

The compound search results are displayed in the Compound Results table in 
the lower part of the tab.

3 Click on a compound of interest in the Compound Results table. The PCDL 
spectra associated with the selected compound are displayed in the Spectral 
Results table in the middle of the tab. In this case, the search parameters set in 
the top of the tab are ignored.

4 Click on a row of the Spectral Results table to view the mass spectrum plot for 
the selected spectrum in the Spectral Plot Window to the right of the table.

5 Click the Mass Lists tab in the Spectral Plot window to view a list of masses and 
abundance values for the selected spectrum.

6 Repeat Steps 3 - 5 for other compounds of interest.
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To add, move, or remove spectra in a custom PCDL

1 Enable editing of the current PCDL by marking Allow Editing on the 
Database/Library menu.

2 Do a compound search using either of the following:

• “To find compounds” on page 17.

• “To find compounds from a mass list” on page 21.
3 When the compound search is complete, click the Edit Spectra tab.

The compound search results are displayed in the Compound Results table in 
the lower part of the tab.

4 Click on a compound you want to view or modify in the Compound Results 
table. The spectra associated with the selected compound are displayed in the 
Library spectra table in the middle of the tab.

5 Load spectra into the Acquired spectra table at the top of the tab in either of 
the following ways:

• From .CEF file as described in “To import spectra from a .CEF file” on 
page 29, or

• From Qualitative Analysis, as described in “To copy spectra from 
MassHunter Qualitative Analysis” and “To paste spectra into MassHunter 
PCDL Manager” on page 30.

6 To add spectra to the compound selected in Step 4:

a Click to select the spectrum of interest in the Acquired Spectra table. 
Multiple spectra can be selected using Ctrl+click or Shift+click.

b Click the Add Spectra button. The Library spectra table will be updated to 
show the new list of spectra for the compound.

7 To delete spectra from the compound selected in Step 4:

a Click to select the spectrum of interest in the Library spectra table. Multiple 
spectra can be selected using Ctrl+click or Shift+click.

b Click the Delete Spectra button. The Library spectra table will be updated to 
show the revised list of spectra for the compound.

NOTE The information about the spectra such as collision energy, ion polarity, ionization mode, 
and instrument type cannot be edited. The acquisition parameters used for data acquisition 
are stored with the spectra in the PCDL.
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8 To move spectra between compounds:

a Click to select the compound to copy spectra from in the Compound Results 
table in the lower part of the tab. 
The spectra for that compound are displayed in the Library spectra table in 
the middle of the tab.

b Click to select the spectra of interest in the Library spectra table, then 
right-click in the table and select Copy Spectra from the shortcut menu. Use 
Ctrl-click or Shift-click before copying if you want to select multiple spectra.

c Right-click in the Acquired spectra table in the upper part of the tab and 
select Paste Spectra from the shortcut menu. 
The spectra are added to the Acquired spectra table.

d Click to select the compound to copy the spectra to in the Compound Results 
table in the lower part of the tab.

e Click the Add Spectra button.
The Library spectra table will be updated to show the revised list of spectra 
for the compound.

To clean up noisy spectra

Use this procedure to remove small noise peaks from spectra before or after you 
add them to a custom PCDL.
1 Select the spectrum of interest in either the Acquired spectra or Library 

spectra table on the Edit Spectra tab.
2 Click the Mass Lists tab in the Spectral Plot window. By default, the masses are 

sorted in descending order by relative abundance value. Click the Rel Abund 
column header if you want the lowest relative abundance values (likely noise 
peaks) to appear at the top of the table.

3 Select the masses to delete by clicking on them in the Acquired masses or 
Library masses list. Use Ctrl-click or Shift-click to select multiple masses.

4 Right-click in the Acquired masses or Library masses list and select Delete 
Masses from the shortcut menu.

5 Update the PCDL as follows, depending on whether the spectrum modified in 
Step 4 was an Acquired or Library spectrum.

• Click the Add Spectra button to add an Acquired spectrum to the selected 
library compound.

• Click the Update Spectra button to update the selected library compound 
with a modified Library spectrum.
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Familiarization Exercises

These exercises will help you learn to use the MassHunter PCDL Manager:

• “Exercise 1. Search for compounds in a PCDL” on page 34

• “Exercise 2. Batch search from a mass list” on page 37

• “Exercise 3. Create a custom PCDL” on page 41

• “Exercise 4. Edit compounds” on page 42

• “Exercise 5. Add retention times to a PCDL” on page 44

PCDL operations:

• “Exercise 6. Search a PCDL” on page 49

• “Exercise 7. Browse spectra in the library” on page 51

• “Exercise 8. View spectra for compounds” on page 53

Exercise 1. Search for compounds in a PCDL

In this exercise, you will search for compounds in the master Forensic Toxicology 
PCDL and review the search results.

Steps Detailed Instructions Comments

1 Open the master PCDL. a Select Open Database/Library from 
the File menu, or click the  button 
on the toolbar.

b Select the 
PCDL\ForensicsTox_AM_PCDD.cdb 
file, and click the Open button.

Skip this step if the master PCDL is 
already open.

2 Click the Single Search tab.

3 Leave the search fields blank. Be sure that the Require checkbox for 
Retention time is cleared, since the 
master Forensic Toxicology PCD and 
PCDL do not contain retention time 
information.

This will return all compounds in the 
PCDL. See “To find compounds” on 
page 17 for a discussion of search 
parameters to narrow your search.

4 Begin searching. Click the Find Compounds button on the 
toolbar.

Alternate methods:
• Select Find Compounds from the 

Database/Library menu.
• Press the F5 key.

5 Review the search results in the 
table in the lower half of the tab.

See Figure 1 on page 36. The results are sorted from low mass 
to high mass.
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6 View structure information for a 
selected compound.

Click on a compound in the Compound 
Results table. Its structure is displayed in 
the Structures area on the right side of 
the window.

• Clicking the  button displays a 
larger image of the structure.

• Clicking the MOL Text tab displays 
the text version of the structure. 

7 Sort the table by name. Click the heading of the Compound Name 
column. Click it again to sort by name in 
the opposite order.

Clicking on any column heading will 
sort the table according to the values 
in that column.

8 Reorder the columns in the table. a Drag a column heading to a different 
position. 

b Repeat until the desired order is 
achieved. 

9 Resize a column. You can resize columns in either of the 
following ways:
• Double-click on the right column 

divider in the heading of the column of 
interest to resize the column to fit the 
information contained in it.

• Drag the separator between column 
headings to the right or left until the 
column of interest is the desired width.

10 Change which columns of 
information are displayed in the 
table.

a Right-click in the table and select 
Add/Remove Columns from the 
shortcut menu. 

b Move the items of information that you 
want to display from the Available 
columns list into the Show these 
columns list using the Add-> button.

c Move the items of information that you 
don’t want to display out of the Show 
these columns list into the Available 
columns list using the <-Remove 
button.

d Click OK. 

Alternate Methods:
• You can also open the Add/Remove 

Columns dialog box by selecting 
Add/Remove Compound Columns 
from the View menu.

• You can move individual items 
between the two lists by 
double-clicking them.

Note that the original column layout 
can be restored at anytime by 
selecting Restore Default Compound 
Columns from the View menu.

Steps Detailed Instructions Comments
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Figure 1 Results of Single Search for Forensic Toxicology

11 Print results. a Click the  button on the toolbar to 
open the Print Results dialog box.

b Select print options. For a discussion 
of print options, see “To print 
compound results” on page 20.

c Click OK. If you selected the Print 
Preview option, review the report in 
the Print Preview window, then click 
the  button to print it.

To print only selected results, highlight 
those rows in the Compound Results 
table using Ctrl+click or Shift+click, 
then select Only highlighted rows as 
one of the print options in Step c.

Steps Detailed Instructions Comments
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Exercise 2. Batch search from a mass list

In this exercise, you will search the master Forensic Toxicology PCDL using an 
imported mass list.

Steps Detailed Instructions Comments

1 Open the master PCDL. a Select Open Database/Library from 
the File menu, or click the  button 
on the toolbar.

b Select the 
PCDL\ForensicsTox_AM_PCDD.cdb 
file, and click the Open button.

Skip this step if the master Forensics 
PCDL is already open.

2 Click the Batch Search tab.

3 Open a mass list. a Click the File button to the left of the 
mass list table.

b Select the tox_compounds.txt mass list 
file in the PCDL\Mass List Files folder. 

c Click the Open button.

• Mass lists can also be 
copy-and-pasted into MassHunter 
PCDL Manager from MassHunter 
Qualitative Analysis.

• See online help in MassHunter
Qualitative Analysis for instructions 
on how to output a mass list.

4 Set the batch search parameters. In this case the following default search 
parameters can be used for the search:
• Neutral Masses option marked.
• Mass tolerance 10 ppm.
• Optional for Retention times marked.
• Only the Include neutrals option 

marked for Ion search mode.

The Forensic Toxicology PCD and 
PCDL do not include retention times.

5 Begin searching. Click the Find Compounds button on the 
toolbar.

You can also start the search in either of 
the following ways:
• Select Find Compounds from the 

Database/Library menu.
• Press the F5 key.

6 Review search results. When the search is complete, the number 
of hits for each mass appears in the Hits 
column of the mass list, and the list is 
automatically sorted to show the masses 
with the most hits at the top of the list. See 
Figure 2 on page 39. 

• To sort the mass list by a different 
criterion, click the heading for the 
column of interest.

• Masses with conflicting hits are 
shown in red text in the Mass List 
table. 
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7 View hits for selected masses. Click on a row in the Mass List table to 
display the compounds found for that mass 
in the Batch Search Results table in the 
lower part of the window. 

For ease of reviewing results, use the 
F4 key to scroll down the Mass List and 
the Shift+F4 keys to scroll back up. The 
information in the results table will be 
updated as you scroll through the mass 
list.
The batch search results table can be 
resorted as described in “To change 
how data is displayed in results tables” 
on page 19.

8 Select the best compound hit for 
each mass.

Mark the Best column for the row 
(compound) you believe is the best 
compound hit for each mass. In many 
cases, this will be the one already selected 
by the software.

You can also clear the box for the 
selected hit to ignore that mass.

9 View the best hit results. Click the Batch Summary tab. The Best hit 
for each mass is shown in the Batch 
Summary table in the lower part of the 
window. See Figure 3 on page 40.

Compounds with conflicting mass hits 
are shown in red text in the results 
table.
The batch summary results table can be 
resorted as described in “To change 
how data is displayed in results tables” 
on page 19.

10 Export batch summary results. a Click the  button on the toolbar to 
open the Export Results dialog box.

b Select the following options: Search 
parameters, Results, and Unmatched 
masses.

c Mark the Open results file after 
exporting option.

d Click OK to output the results. 
The results will open in the associated 
application such as Excel.  
The following export file is created in 
the MassHunter\PCDL\Results folder: 
pest_compounds-<timestamp>.txt

You can also open the Export Results 
dialog box in either of the following 
ways: 
• Select Export Results from the File 

menu.
• Right-click in the Batch Summary 

results table and select Export 
Results from the shortcut menu.

You can select a different file name, 
location or type as described in “To 
export batch summary results” on 
page 25.

Steps Detailed Instructions Comments
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Figure 2 Results of Batch Search - Mass List
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Figure 3 Batch Summary Results
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Exercise 3. Create a custom PCDL

In this exercise, you will create a custom PCDL that is a subset of the 
Forensics-Toxicology PCDL.

Steps Detailed Instructions Comments

1 Open the New Database/Library 
dialog box.

Select New Database/Library from the 
File menu or click the  button on the 
toolbar.

2 Create the new PCDL. a Browse to \PCDL.
b Select Forensics as the starting PCDL. 
c Select Forensics as the 

database/library type.
d Type in a name for the new PCDL, such 

as For_Subset.
e Enter a description for the new PCDL. 
f Click the Create button to create the 

new PCDL. 

• The new PCDL becomes the 
current working PCDL and is 
automatically enabled for editing. 

• The new custom PCDL will contain 
all compounds and spectra from the 
starting PCDL.

3 Edit the PCDL. See “Exercise 4. Edit compounds” on 
page 42.
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Exercise 4. Edit compounds

In this exercise, you edit the custom PCDL that you created in Exercise 3.

 

Steps Detailed Instructions Comments

1 Open the custom PCDL you created 
in Exercise 3, if it is not already 
open.

a Select Open Database/Library from 
the File menu, or click the  button 
on the toolbar.

b Select the PCDL\For_Subset.cdb file, 
and click the Open button.

Skip this step if the custom PCDL is 
already open, as it will be if you just 
completed Exercise 3.

2 Enable editing for this PCDL. a Open the Database/Library menu.
b Mark Allow Editing if it is not currently 

marked.

A new PCDL is automatically enabled 
for editing when it is created.

3 Do a search. a Click the Single Search tab.
b Click the Find Compounds button on 

the toolbar to start the search. The 
search results appear in the table in 
the lower half of the window.

This search returns all neutral mass 
compounds in the PCDL.

4 Click the Edit Compounds tab.

5 Update information for a particular 
compound.

a Select the compound of interest by 
clicking on it in the Compound Results 
table. 

b Update information on the left side of 
the Edit Compounds tab, such as 
Mass, RT, Formula, Name, CAS ID, and 
Ion type.

c Click the Update Selected button to 
apply the changes to the PCDL. 

Information for the selected compound 
is displayed in the Edit Compounds 
tab.

The updated information will be 
changed in the PCDL and reflected in 
the results table. 

6 Update structure information for a 
particular compound.

a Select the compound of interest by 
clicking on it in the Compound Results 
table. 

b Click the  button in the 
Molecule area to open a .MOL file. 

c Click the Update Selected button. The 
information you entered will be 
changed in the library.

You can also update structure 
information for a selected compound 
by clicking on the MOL Text tab and 
pasting in MOL file text that you 
copied from a molecular drawing tool 
(Ctrl+V).
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7 Add a new compound to the PCDL. a Click the Add New button.  
A new compound is created in the 
PCDL with a mass of 0 named “New 
Compound”, and the new compound is 
displayed at the end of the Compound 
Results table.

b Enter or change information for the 
new compound as described in Step 5 
above.

c Click the Update Selected button.  
The information you entered for the 
new compound is updated in the PCDL 
and the information is reflected in the 
results table.

Alternate method: 
a Enter information for a new 

compound on the left side of the 
Edit Compounds tab, such as Mass, 
RT, Formula, Name, and Ion type.

b Click the Save As New button.  
A new compound is created in the 
PCDL using the specified values. 
The new compound is displayed at 
the end of the results table.

8 Remove a compound from the 
PCDL.

a Select the compound of interest by 
clicking on it in the Compound Results 
table. 

b Click the Delete Selected button. 

The selected compound is removed 
from the PCDL.

9 Add retention times to the PCDL as 
described in Exercise 5.

Steps Detailed Instructions Comments
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Exercise 5. Add retention times to a PCDL

In this exercise, you add retention times to the custom PCDL created in Exercise 3 
and edited in Exercise 4.

 

Steps Detailed Instructions Comments

1 Open the custom PCDL you created 
in Exercise 3 and edited in Exercise 
4, if it is not already open.

a Select Open Database/Library from 
the File menu, or click the  toolbar 
button.

b Select the PCDL\For_Subset.cdb file, 
and click the Open button.

2 Enable editing for this PCDL. a Open the Database/Library menu.
b Mark Allow Editing if it is not currently 

marked.

A new PCDL is automatically enabled 
for editing when it is created.

3 Click the Batch Search tab.

4 Open a mass list file that contains 
retention time information for the 
masses.

a Click the File button to the left of the 
mass list table.

b Select tox_compounds.txt in the 
PCDL\Mass List Files folder.

c Click the Open button.

Each mass in the mass list must have 
an associated retention time value.

5 Set the search parameters. a Set the Mass tolerance to 10 ppm.
b Mark Retention times Optional.
c Set the RT tolerance to 1 minute as 

shown below:

6 Start the search. Click the Find Compounds toolbar button.
The number of hits for each mass appears 
in the Hits column of the mass list. 
Masses with conflicting hits are shown in 
red text in the Mass List. See Figure 4.

To sort the list by a different criterion, 
click the heading for the column of 
interest.
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7 View hits for selected masses. Click on a row in the Mass List table to 
display the compounds found for that 
mass in the Batch Search Results table in 
the lower part of the window. 

For ease of reviewing results, use the 
F4 key to scroll down the Mass List 
and the Shift+F4 keys to scroll back 
up. The information in the results table 
will be updated as you scroll through 
the mass list.
The batch search results table can be 
resorted as described in “To change 
how data is displayed in results 
tables” on page 19.

8 Select the best compound hit for 
each mass.

Mark the Best column for the row 
(compound) you believe is the best 
compound hit for each mass. In many 
cases, this will be the one already 
selected by the software.

You can also clear the box for the 
selected hit to ignore that mass.

9 Click the Batch Summary tab. See Figure 5.

10 Update retention times in the PCDL 
from the current mass list.

Click the Apply Retention Times button.
Note that this button is unavailable until 
all conflicting hits are resolved as 
described in Step 8.

Retention time information is updated 
in the PCDL for each of the compounds 
listed in the Batch Summary table. See 
Figure 6.

Steps Detailed Instructions Comments
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Figure 4 Batch Search Results with Retention Time Optional
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Figure 5 Batch Summary Results with Retention Time Optional (before updating)
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Figure 6 Batch Summary Results with Retention Times Updated
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Exercise 6. Search a PCDL

In this exercise, you will load spectra from a .CEF file and search for spectra in an 
example library.

 

Steps Detailed Instructions Comments

1 Open the example SulfasLib library. a Select Open Database/Library from 
the File menu, or click the  button 
on the toolbar.

b Select the Library\SulfasLib.cdb file, 
and click the Open button.

2 Import spectra. a Click the  button on the 
Spectral Search tab.

b Select the Sulfas.cef file in the 
Example Data folder on the 
MassHunter Personal Compound 
Database and Library Manager disk.

c Click the Open button.
d When the message “Any profile or 

non-MS/MS spectra were skipped” 
appears, click OK.

• See online help in MassHunter 
Qualitative Analysis for instructions 
on how to output spectra to a .cef 
file.

• This message appears when the 
import file contains Profile spectra 
or non-MS/MS spectra, as is the 
case in the example .cef file. Only 
centroided MS/MS spectra are 
imported for use in MassHunter 
PCDL Manager.

The imported spectra appear in the 
Acquired spectra table in the upper part of 
the tab.

Often the Compound Name field will 
be blank. Compound Name is shown 
only if the compound was identified in 
MassHunter Qualitative Analysis 
before the cef file is exported.

3 Select the spectrum to search. Click on the Sulfamethazine row in the 
Acquired spectra table that has Collision 
Energy value of 0. 

4 Set search parameters. Clear the check mark for the Collision 
energy Filter.

Use default values for the other search 
parameters.

5 Start searching. Click the Find Spectra button on the 
toolbar.

You can also start the search in either 
of the following ways:
• Select Find Spectra from the 

Database/Library menu.
• Press the F5 key.
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Figure 7 Spectral Search Results

6 View search results. The library search results are displayed in 
the Library spectra table in the lower part 
of the tab.  
In this case, two library spectra are 
returned by the search, as shown in 
Figure 7 below.

If desired, the spectral results display 
can be changed as described in “To 
change how data is displayed in 
results tables” on page 19.

7 Select a different results spectra. Click on a different row of the Library 
spectra table.

Notice that the lower spectrum in the 
Graphics tab of the Spectral Plot 
Window to the right of the table is 
updated.

8 View the mass list. Click the Mass Lists tab in the Spectral 
Plot window.

Steps Detailed Instructions Comments
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Exercise 7. Browse spectra in the library

In this exercise, you will search an example library for spectra that match certain 
parameters, such as mass, collision energy, ion polarity, and ionization mode.

 

Steps Detailed Instructions Comments

1 Open the example SulfasLib library. a Select Open Database/Library from 
the File menu, or click the  button 
on the toolbar.

b Select the Library\SulfasLib.cdb file, 
and click the Open button.

Skip this step if the SulfasLib library is 
already open, as it will be after 
Exercise 6.

2 Display the Browse Spectra tab. Click to display the Browse Spectra tab.

3 View all compounds in the library. a Use the default search parameters:
• Precursor Ion Mass and Collision 

energy blank
• Ion polarity (Any)
• Ionization mode (Any)

b Click the Find Spectra button on the 
toolbar to start the search.

4 View spectral information. View Compound Name, Precursor Ion, 
Collision Energy, Ion Polarity, Ionization 
Mode, and Instrument type in the 
Spectral Search Results table in the 
middle of the tab. See Figure 8 on 
page 52.

5 View the mass spectrum plot for 
one of the spectra.

a Click on a row of the results table to 
select a spectrum.

b Click the Graphic tab in the spectral 
plot window to the right of the table.

6 View the mass list for the selected 
spectra.

Click the Mass List tab in the spectral plot 
window.

7 Filter spectra by Precursor ion 
mass.

a Set the Precursor ion mass to 279.09.
b Click the Find Spectra button on the 

toolbar to start the search.

Note that only the three 
Sulfamethazine spectra are returned.
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Figure 8 Browsing Spectra Results

8 Reset the default search 
parameters.

a Right click in the upper part of the 
Browse Spectra tab and select Reset 
Search Fields from the shortcut menu.

9 Filter spectra by Collision energy 
voltage.

a Set the Collision energy to 40.
b Click the Find Spectra button on the 

toolbar to start the search.

Note that the four spectra are returned 
by the search that have Collision 
Energy values of 40,

Steps Detailed Instructions Comments
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Exercise 8. View spectra for compounds

In this exercise, you will view mass spectra for the compounds in an example 
library.

 

Steps Detailed Instructions Comments

1 Open the example SulfasLib library. a Select Open Database/Library from 
the File menu, or click the  button 
on the toolbar.

b Select the PCDL\SulfasLib.cdb file, 
and click the Open button.

Skip this step if the SulfasLib library is 
already open, as it will be after 
Exercise 7.

2 Click on the Single Search tab.

3 Leave the search fields blank. Be sure that the Require checkbox for 
Retention time is cleared, since the 
example library does not contain 
retention time information.

This will return all compounds in the 
PCDL. See “To find compounds” on 
page 17 for a discussion of search 
parameters to narrow your search.

4 Begin searching. Click the Find Compounds button on the 
toolbar.

Alternate methods:
• Select Find Compounds from the 

Database/Library menu.
• Press the F5 key. 

5 Display the Browse Spectra tab. Click to display the Browse Spectra tab. This procedure can also be performed 
from the Edit Spectra tab.

6 Select Sulfamethizole from the 
Single Search Results table.

Click on the Sulfamethizole row of the 
Single Search Results table.

The Single Search Results table is in 
the lower part of the tab and should 
contain the compound results from 
Exercise 1.

7 View the spectral information for 
Sulfamethizole.

View Compound Name, Precursor Ion, 
Collision Energy, Ion Polarity, Ionization 
Mode, and Instrument type in the 
spectral information table.

The spectral information table is in the 
middle of the tab.

8 View the mass spectrum plot for 
Sulfamethizole.

Click the Graphic tab in the spectral plot 
window.
See Figure 9 on page 54.

The spectral plot window is on the 
right side of the tab.

9 View the mass list for 
Sulfamethizole.

Click the Mass List tab in the spectral plot 
window.
MassHunter PCDL Manager Quick Start Guide 53



Figure 9 Viewing spectral information for Single Search results

10 View information for another 
Sulfamethizole spectrum.

a Click on a different row of the spectral 
information table.

b View the mass spectrum and mass list 
for this spectrum in the Spectral Plot 
Window as described in Steps 8 and 9.

Different mass spectra were obtained 
for Sulfamethizole by acquiring data 
with three different Collision Energy 
values: 10, 20, and 40.

11 View spectral information for a 
different compound.

Click on the Sulfamethazine row of the 
Single Search Results table in the lower 
part of the tab.

View the spectral information for this 
compound as described in Step 7.

Steps Detailed Instructions Comments
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