
This guide shows you how to review the graphical and tabular data in 
Compound Discoverer™ result files (.cdResult). You can review the 
data without an active software license.

A result file opens as a tabbed document with three main views: the 
Chromatogram View, the Mass Spectrum View, and a set of up to ten 
master tables. The Chromatogram View and Mass Spectrum View 
are independent graphical views; that is, working in one view does 
not affect the other view. The graphical views are empty until you 
select a row in one of these tables: Consolidated Peaks, Expected 
Compound Hits, Unknown Compound Hits, Expected 
Compounds, Unknown Compounds, Specialized Traces, or FISh 
Trace Fragments. 

Depending on the processing workflow, the result page contains one 
or more of the following master tables. 

The Custom Explanations table appears when the workflow contains 
the Peak Consolidator node; however, the table is empty until you 
create a custom explanation for an expected compound hit or 
unknown compound hit. 
The Manual Peaks table (not shown) appears when you add a manual 
peak to a trace in the Specialized Traces table (see “To integrate 
chromatographic peaks manually” on page 2).
By default, the Adducts table (not shown) is hidden.

There are several ways to open a result file.
• From the Compound Discoverer menu bar, choose File > Open 

Result.
• On the Start Page, click the result file name, which is displayed in 

blue hypertext.
If the Start Page is closed, open it by choosing View > Start Page 
from the Compound Discoverer menu bar.

• From the Job Queue page, double-click a completed run. 
If the Job Queue page is closed, open it by choosing View > Job 
Queue from the Compound Discoverer menu bar.

• From the Analysis Results page of a study, select the completed 
run of interest and click Open Result in the Analysis Results 
command bar.

You can change the following views to floating windows: the 
Chromatogram View, Mass Spectrum View, Result Filters view, 
Scatter Chart view, and Summaries view.

 To enlarge the views
1. Double-click the view’s title bar to make it a floating window.
2. Drag the view to a second monitor.
3. Enlarge the view by dragging its edges.

The Chromatogram View is empty until you select a row in one of 
these tables: Consolidated Peaks, Expected Compounds, Expected 
Compound Hits, Unknown Compounds, Unknown Compound 
Hits, FISh Trace Fragments, or Specialized Traces.
Follow these procedures as needed:
• To view a chromatogram
• To overlay chromatograms in one plot
• To integrate chromatographic peaks manually
• To apply a shortcut menu command in the Chromatogram View
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 To view a chromatogram 
Do one of the following:
• Click the Consolidated Peaks tab and select a row.

The Chromatogram View displays the chromatographic peaks 
detected by both the Unknown Detector node and the Expected 
Finder node. 

• Click the Expected Compound Hits tab or the Unknown 
Compound Hits tab and select a row.
The Chromatogram View displays the integrated 
chromatographic peak for the selected table row.

• Click the Expected Compounds tab or the Unknown 
Compounds tab and select a row.
The Chromatogram View displays a composite trace of all the 
chromatographic peaks detected for the molecular weight listed 
in the selected table row.

• Click the FISh Trace Fragments tab and select a row.
The Chromatogram View displays a trace for the structure 
displayed in the selected table row. The application displays the 
FISh Trace Fragments table when you select True for Individual 
Traces in the FISh Tracer node.

• Click the Specialized Traces tab, and then select a row.
Depending on the processing workflow, the Specialized Traces 
table can contain the following traces: 
 A Mass Tracer node can generate any of these traces: extracted 

ion (mass range) chromatogram (XIC), base peak 
chromatogram (BPC), or total ion chromatogram (TIC).

 An Analog Tracer node can generate any of these traces: a 
UV-Vis trace from a UV-Vis or PDA detector, up to three 
traces from a PDA detector, or an analog trace from an LC 
detector that is connected to one of the analog input channels 
of a Thermo Scientific mass spectrometer.

 A Pattern Tracer node generates a TIC trace by summing the 
mass spectral peaks (across the entire scan) that match the 
user-defined isotope pattern.

 A FISh Tracer node generates the following:

• A summed FISh trace of all the matching fragment ion 
scans (DDF or AIF) when you select True in the Summed 
Trace list. 

• An individual FISh trace for each fragment ion when you 
select True in the Individual Traces list. To view the 
individual trace for each fragment ion, see the FISh Trace 
Fragments table.

 To overlay chromatograms in one plot
1. Select a table row.
2. Do one of the following:

• Hold down the SHIFT key and select the last row in the 
contiguous range that you want to overlay.

• Hold down the CTRL key and individually select the rows 
that you want to overlay.

• Hold down the SHIFT key and use the Down Arrow key to 
select a range of rows.

 To integrate chromatographic peaks manually
1. In the Specialized Traces table, select the trace of interest.
2. Right-click the Chromatogram View and choose Manual Peak 

Integration from the shortcut menu.
Two red dashed lines appear.

3. Drag one line to the beginning of the chromatographic peak and 
the other line to the end of the chromatographic peak.
The application highlights the integrated peak area in blue.

4. Move the cursor over the peak.
A pop-up box appears with the selected retention time range and 
Apply and Cancel buttons.

5. To add the manual peak to the Manual Peaks table, click Apply, 
or press the A key on the keyboard. 
If the result file did not already contain a Manual Peaks table, the 
new table appears in the master table tab set. The Manual Peaks 
table contains a row for the new manual peak.

 To apply a shortcut menu command in the Chromatogram View
Right-click the Chromatogram View and choose a command 
from the shortcut menu (Table 1).

Table 1. Chromatogram View–Shortcut menu commands (Sheet 1 of 2)

Command Description

Undo Last 
Zoom/Pan

Undoes the last zoom or pan movement.

Undo All 
Zoom/Pan

Zooms out to the full data acquisition time for 
the chromatogram on the x axis and the height 
of the largest chromatographic peak on the 
y axis.

Keep Zoom Maintains the same zoom range, as you select 
components with different peak areas. Overrides 
the Zoom to Detected Peaks command as you 
select different table rows.

Copy Image Copies an image of the Chromatogram View 
(including the legend) to the Clipboard. You can 
paste the image into a Microsoft Office 
document as a raster image or into a 
vector-drawing program as a vector image.

Copy Points Copies the data as a two-column list of data 
points and the legend. The first column lists the 
retention time and the second column lists 
either the relative intensity or the counts. 
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The Mass Spectrum View contains a spectral tree on the left and the 
mass spectrum of the selected scan on the right.
In addition to the MS1 scans, the spectral tree also displays matching 
data-dependent (DDF) scans and all ions fragmentation (AIF) scans. 
When the processing workflow includes the FISh Scoring node, you 
can view the annotated fragment structures in the Mass Spectrum 
View for a selected fragmentation scan (DDF or AIF).
Follow these procedures as needed:
• To display a mass spectrum
• To zoom in or out on the x axis of the Mass Spectrum View
• To apply a shortcut menu command in the Mass Spectrum View
• To interpret the color coding in the full MS scans for the 

Expected Compound Hits
• To view the matching fragment structures predicted by the FISh 

Scoring node
• To create a mirror plot

 To display a mass spectrum
Select a row in the Expected Compound Hits table or the 
Unknown Compound Hits table.
The Mass Spectrum View displays the matching spectral tree and 
a zoomed-in view of the full MS scan.

 To zoom in or out on the x axis of the Mass Spectrum View
• To zoom in, drag the cursor to the right over the m/z range of 

interest.
• To zoom out, drag the cursor to the left over the m/z range of 

interest.

 To apply a shortcut menu command in the Mass Spectrum 
View
Right-click the Mass Spectrum View and choose a command 
from the shortcut menu (Table 2). 

Save Image As Opens the Save As dialog box where you can 
specify a file name and save the contents of the 
Chromatogram View as one of these selectable 
image formats: EMF, PNG, GIF, JPG, TIFF, or 
BMP. The PNG, GIF, JPG, TIFF, and BMP 
formats are raster images. 

Save Points As Opens the Save As dialog box where you can 
specify a file name and save the contents of the 
Chromatogram View as a text file. The default 
file name is Chart.txt. 

Show ToolTips Displays a pop-up box with information about 
the trace when you place the cursor, +, over a 
chromatographic peak. 

Show Gridlines Adds grid lines to the Chromatogram View.

Show Detected 
Peaks

Shades the integrated area within the detected 
chromatographic peaks a light gray. Turning off 
this command removes the shading.

Show Legend Displays a legend at the top of the view. The 
displayed information depends on the selected 
trace. 

Legend Size Specifies the selected number (1–10) of legend 
lines that you want the application to display.

Relative 
Intensity

Displays the y-axis scale as relative intensity 
(0–100%).

Zoom to 
Detected Peaks

Zooms in on the detected peak or peaks.

Add Plot Adds an empty, active plot to the 
Chromatogram View. Only the screen size limits 
the maximum number of displayed plots. When 
you reach the screen’s limit, the Chromatogram 
View appears to be empty and the following 
message appears—Not enough space for 
drawing chart properly.

Remove Plot Removes the active plot, which has a gray 
border. Adding more than one plot activates this 
command.

Remove All 
Plots

Removes all of the plots in the Chromatogram 
View.

Freeze Content Keeps the chromatogram of the currently 
selected row in the view when you select another 
row.

Clear Frozen 
Content

Clears the frozen chromatogram from the view.

Manual Peak 
Integration

Use to add a manual peak to a specialized trace. 
Adding a manual peak adds the Manual Peaks 
table to a result file. Selecting a trace in the 
Specialized Traces table activates this command. 

Table 1. Chromatogram View–Shortcut menu commands (Sheet 2 of 2)

Command Description
Working with the Mass Spectrum View

Table 2. Mass Spectrum View–Shortcut menu commands (Sheet 1 of 2)

Command Description

Undo Last 
Zoom/Pan

Undoes the last zoom or pan movement.

Undo All 
Zoom/Pan

Zooms out to the full scan range.

Copy Image Copies the mass spectrum as a bitmap (raster) 
image to the Clipboard.
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 To interpret the color coding in the full MS scans for the 
Expected Compound Hits
The full MS scan shows the isotope pattern for the detected 
compound. Colored rectangles highlight the mass spectrum peaks 
(centroids) that match the theoretical isotope pattern.

This figure shows a full MS scan with four matching isotopes for 
omeprazole (C17 H19 N3 O3 S). The second A2 isotope is not 
visible at the normal zoom level.

 To view the matching fragment structures predicted by the 
FISh Scoring node

1. Enlarge the view (see “To enlarge the views” on page 1).
2. In the spectral tree, select an MS/MS or higher scan. 

The FISh Scoring node annotates centroids that match the 
m/z value of a theoretical fragment ion with its theoretical 
structure and color codes the centroids in a fragmentation scan.

 To create a mirror plot
1. In the spectral tree pane, select the scan that you want to use as a 

reference scan.
2. Right-click the Mass Spectrum View and choose Use as 

Reference from the shortcut menu.
3. Select a scan for the compound that you want to compare.

This figure shows a mirror plot for omeprazole and one of its 
glucuronide conjugation products. The omeprazole 
fragmentation scan (reference scan) is on the bottom.

Copy Points Copies the data points and the scan header for 
the selected scan to the Clipboard. Also copies 
the FISh annotations.

Copy Raw 
Points

Copies the data points for the selected scan to 
the Clipboard. Use this command to copy 
points to a library search application.

Save Image As Opens the Save As dialog box, where you can 
type a name and select a file type for the current 
scan. The available file types are BMP, EMT, 
GIF, JPG, PNG, and TIF.

Save Points As Opens the Save As dialog box, where you can 
type a name and select a file type for the current 
scan. The available file type is TXT. 

Use as Reference Creates a mirror plot that initially consists of the 
currently selected scan. When you select another 
scan, the reference scan remains in the –y-axis 
portion of the graph, and the new scan appears 
in the +y-axis portion of the graph.

Clear Reference Removes the reference plot from the Mass 
Spectrum View.

Color Meaning 

( ) Lavender The labeled centroid is the monoisotopic mass 
of the expected compound ion.

( ) Green The labeled centroid matches the delta mass and 
relative intensity of the theoretical isotope 
pattern.

( ) Red The expected centroid for this m/z value is 
missing or its intensity does not fall within the 
tolerance range for the theoretical isotope 
pattern.

( ) Light blue The centroid for this m/z value might be missing 
because its theoretical intensity is at the level of 
the baseline noise.

Table 2. Mass Spectrum View–Shortcut menu commands (Sheet 2 of 2)

Command Description

Enlarged 
view of 
A2s

A0 A1 A2s

Mass spectrum peak Delta 
mass 

Relative 
intensity

A0 monoisotopic protonated molecule 0 100.0%

A1 protonated molecule with one 13C 1.00339 19.0%a

a Carbon is an X + 1 element. The relative abundance of the stable 13C isotope is 1.1%. 
The relative intensity of the A1 isotopic peak is approximately equal to 1.1nc, where 
nc is the number of carbon atoms.

A2 protonated molecule with one 34S 1.99567 4.4%b

b Sulfur is an X + 2 element. The relative abundance of the stable 34S isotope is 4.22%. 
The relative intensity of the A2 isotopic peak (one 34S) is approximately equal to 
4.4ns, where ns is the number of sulfur atoms.

A2 protonated molecule with two 13C 2.00603 1.7%

Color Meaning

( ) Green Direct match

( ) Blue Shifted match
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Follow these procedures as needed:
• To sort the table columns
• To create, apply, and save data reduction filters
• To save the current filter settings for reuse
• To decide whether an unknown compound is a compound of 

interest

 To sort the table columns
• To sort a column, click the column header. Click the column 

header a second time to reverse the sort order.
• To sort multiple columns, click the column header of the first 

column you want to sort by. Then, while holding down the 
CTRL key, click the column header of the second column that 
you want to sort by.

 To create, apply, and save data reduction filters
1. From the Compound Discoverer menu, choose View > Result 

Filters.
The Result Filters view opens as a floating window and displays 
the filter tree for the current table. Each table has its own set of 
filter conditions. Filtering one table has no effect on any other 
table.

2. In the left pane of the view, select a table of interest.
The table name appears in the right pane. The following selection 
tree appears below the table name.

3. Set up a filter condition as follows:
a. Click Add Property.

A list that includes the columns in the selected table and the 
AND and OR logic selections appears.

b. Select the property (table column) that you want to filter by.
An expression box with a default selection and an empty value 
box appear to the right of the selected property. In addition, 
another Add Property button appears below the filter 
expression that you are currently editing.

c. Select an expression and type a value in the value box if 
applicable. To view only the checked table rows, select 
Checked and Is True ( ).

4. Repeat for each filter condition that you want to apply to the 
current table. Repeat steps for each result table that you want to 
filter.

5. To apply the filter conditions, click Apply Filters.

 To save the current filter settings for reuse
1. In the Result Filters window, click Save or Save As.

The Save Filter dialog box opens.
2. Select an appropriate directory folder.
3. Type a name in the File Name box and click Save.

The file name extension is .filterset. 

 To decide whether an unknown compound is a compound of 
interest

1. Click the Consolidated Peaks tab.
2. Select a row of interest.
3. Check whether the unknown compound is found by only the 

Unknown Detector by comparing the results in the Expected 
Finder and Unknown Detector columns.

4. Check whether there are any ion conflicts between the Expected 
Finder and Unknown Detector node by reviewing the Ion 
Conflict column. 

5. Check whether a peak of interest is found in the associated 
control sample by reviewing the In-Control column.

6. To show the related tables, click Show Related Tables. 
7. Click the Unknown Compound Hits tab.

Reviewing the Tabular Data

Table Name
AND Add group

Add property

Tip  Depending on the workflow, the Consolidated Peaks table 
contains up to five status columns. Each status column contains 
two or more parallel columns of colored rectangles, with one 
column for each input file. To view the file names of the input 
files, click the  icon to the right of the column header.

Consolidated Peaks table
Unknown Detector and Expected Finder columns

State Meaning

( ) Gray No match found

( ) Green Single match found

( ) Red Multiple matches found

Consolidated Peaks table– Ion Conflict column

State Meaning

( ) Gray No data to compare, as the related node did 
not detect this ion. 

( ) Green No conflict, as both nodes assigned the same 
ion to this chromatographic peak.

( ) Orange The Unknown Detector node did not detect 
this ion, so the expected compound hit for 
this component might be in doubt. 

( ) Red Either the two nodes assigned different ions 
or one of the nodes assigned more than one 
ion to this m/z value and retention time.

Consolidated Peaks table – In-Control column 

State Sample type Meaning

( ) Gray Sample or 
Control

Not found in the current file

( ) Green Sample Found in both the current file 
and the control file

( ) Purple Control Found in the current file, which 
is a control file

( ) Orange Sample Found but outside the control 
limits

( ) White Sample Found in the current file but not 
in the control file
5



8. Select an unknown compound hit that is not in the control and 
that has a relatively high area count. View the chromatographic 
trace and the scan information.

9. To decide whether the chromatographic peak comes from a 
metabolite of the parent compound, compare it against the FISh, 
Pattern, and analog (UV or PDA) traces for the parent 
compound as follows:
a. Add a plot to the Chromatogram View by right-clicking the 

view and choosing Add Plot from the shortcut menu.
b. Click the Specialized Traces tab and select the FISh trace for 

the sample file. Check whether the FISh trace contains a 
chromatographic peak at the same retention time.

c. Add another plot to the Chromatogram View.
d. Select a Pattern Trace and check whether it contains a peak at 

the same retention time.
e. Add another plot to the Chromatogram View.
f. Overlay the UV or PDA traces for the samples and the 

controls. Check whether the UV or PDA traces contain 
chromatographic peaks at the same retention time as the mass 
chromatogram.

Use the Custom Explanations table to assign structures to 
compounds of interest in the Expected Compound Hits and 
Unknown Compound Hits tables and to run the FISh scoring 
algorithm on the proposed structures.

 To add custom explanations
1. In the Expected Compound Hits or Unknown Compound Hits 

table, right-click the row of interest and choose Add to Custom 
Explanations from the shortcut menu.

2. Click the Custom Explanations tab to display the Custom 
Explanations table.
The table displays a row for your recent addition.

3. To edit the information for the new row, right-click the row and 
choose Edit from the shortcut menu.
The Custom Explanation Editor opens.

4. To assign a name for this custom explanation, type a name in the 
Name box.

5. To assign a structure to this custom explanation, open a MOL file 
or use the drawing tools to draw a structure.
The application checks whether the calculated exact mass of the 
structure matches the molecular weight of the selected peak 
within the mass tolerance (for XIC trace creation) that was 
specified in the Expected Finder or Unknown Detector node. If 
applicable, it also checks whether the proposed elemental 
composition matches the original formula.

6. Rerun the FISh scoring algorithm as follows:
a. Click the FISh Scoring tab.
b. Select the Apply FISh Scoring check box.
c. Select the Use Fragmentation Libraries check box.
d. Click Save. 

Using the proposed structure, the application recalculates the FISh 
Coverage score and annotates the fragmentation spectra.

In a targeted workflow where you connect the Expected Finder node 
to the FISh Scoring node, the FISh Scoring node creates a list of 
expected fragments for each found expected compound. It then 
attempts to match the fragment structures to the centroids in the 
fragmentation scans of the precursor ions.
When only one fragmentation scan follows a precursor ion scan, the 
node calculates the FISh coverage score as follows:

where:
# matched centroids represents the number of matched centroids.
# used centroids represents the number of centroids in the 

fragmentation scan that are above the user-specified 
signal-to-noise threshold.

When a precursor scan is followed by more than one fragmentation 
scan, the node calculates a composite score as follows:

The FISh Scoring node annotates the centroids in the fragmentation 
scans with the matching fragment structures. It also provides a FISh 
Coverage score for data-dependent scans in the Mass Spectrum View 
legend and a Best FISh Coverage score in the Expected Compound 
Hits table.

 To review the processing workflow for a result file
1. From the Compound Discoverer menu bar, choose View > 

Result Summaries.
The Summaries view appears on the result page.

2. Click the Workflow Summary tab and review the processing 
workflow.

Before you close a result file, save the changes that you made to the 
layout if you want the application to remember the changes.

 To save the layout of a result file
From the Compound Discoverer menu bar, choose File > Save.
The application saves the docked positions of the Mass Spectrum 
View, Chromatogram View, Result Summaries view, and Scatter 
Chart view; the rearrangement of the table columns; and the 
applied filter settings.

Trademarks
Compound Discoverer is a trademark of Thermo Fisher Scientific 
Inc. in the United States. 
Fragment Ion Search (FISh) is a trademark of HighChem Ltd. in the 
Slovak Republic.

Adding Custom Explanations

Understanding the FISh Coverage Score

Reviewing the Processing Workflow

Saving the Result File Layout

FISh coverage score # matched centroids
# used centroids

-------------------------------------------------- 100=

FISh coverage score
per all scans# matched centroids 

per all scans# used centroids 
------------------------------------------------------------------------------------------ 100=
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