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What is MassHunter VistaFlux Software?

The Agilent MassHunter VistaFlux software provides you with 
an intuitive workflow to perform your qualitative flux analysis 
and visualize your results on pathways network diagrams. The 
MassHunter tools necessary to perform a qualitative flux 
analysis are referred to collectively as MassHunter VistaFlux 
Software and consists of four software programs. The software 
suite is illustrated in context of the qualitative analysis 
workflow in Figure 1 on page 2.

MassHunter Pathways to PCDL The workflow begins with your experiment design. Pathways to 
PCDL facilitates the creation of a custom personal compound 
database and library (PCDL) from metabolites present in 
pathway content you cull from popular databases such as 



What is MassHunter VistaFlux Software?
BioCyc/MetaCyc, KEGG, and WikiPathways. You can filter and 
select pathways based on database, organism, and/or custom 
text entries to generate a preliminary PCDL that contains 
compounds related to your experiment design.

MassHunter PCDL Manager After your preliminary PCDL is created, PCDL Manager helps 
you manage the compounds and compound content within your 
PCDL to create your target metabolite database used during 
your qualitative flux analysis. You can add new compounds 
manually or from existing PCDLs, remove compounds, and add 
additional compound information, such as formulas, identifiers, 
retention times, and structural information. The compounds in 
your target metabolite database must contain, at a minimum, 
identification, mass, and retention time (based on your sample 
data acquisition method). For identification, use one or more of 
the following examples - molecular formula, CAS, HMP, KEGG.

Figure 1 Illustration of a qualitative flux analysis workflow using MassHunter VistaFlux Software.
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What’s new in 1.0?
MassHunter Profinder Profinder uses your target metabolite database and extracts the 
target metabolites (compound features) and their isotopologues 
from your sample data files. Profinder is optimized to extract 
isotopologue compound features from large data sets and 
provides you with an intuitive user interface to inspect and 
review each compound feature across the files associated with 
your data set. With Profinder, you can review and compare 
extracted ion chromatograms, mass spectral data, and 
isotopologues associated with each compound feature. When 
your extraction method is complete you export your results as a 
Profinder archive file.

Omix Premium Omix Premium is used to create pathways network diagrams 
and view your Profinder results in the context of biochemical 
networks, including isotopologue results. Your Profinder 
archive files, which contain extracted compound features and 
sample group information, are imported into Omix Premium 
where you create customized visualizations of your qualitative 
flux analysis results.

What’s new in 1.0?

• Extend the power of your metabolomics research by studying 
the metabolic network in motion.

• Speed up your analysis using an integrated workflow to 
process isotopologue data.

• Create target lists, extract batch isotopologues, and visualize 
results on pathways.

• Review and edit isotopologue results with ease using an 
intuitive interface.

• Interpret results and communicate with colleagues using 
pathway images and videos of qualitative fluxes.

• Import KEGG or BioCyc content to build pathway models.

• Create confidence in your results using t-test and ANOVA 
statistics on isotopologue data.
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Qualitative Flux Analysis
Qualitative Flux Analysis

Qualitative flux analysis comprises the steps to identify target 
metabolites of interest for your experiment, create visual 
pathways networks for your experiment, acquire accurate mass 
data from your samples, extract accurate isotopic metabolite 
information from the sample data, and then view the results on 
network diagrams of the pathways involved in your experiment. 
A qualitative flux analysis that uses VistaFlux follows the flow 
illustrated in Figure 2.

Figure 2 Workflow to perform an Agilent qualitative flux analysis
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Where to Find More Information
Where to Find More Information

Online Help

Press F1 To get more information about a window or dialog 
box, place the cursor on the window or dialog box of interest 
and press F1.

Help Menu Click Help or Help > Contents, depending on the 
software tool your are using, to access the contents of online 
Help which includes information on wizards, basic tasks, user 
interface, and reference information.

  Click Help for information specific to wizards.

Documents

VistaFlux Software/Omix Premium 

• MassHunter VistaFlux Software - Workflow Guide

• Agilent MassHunter VistaFlux for Qualitative Flux Analysis - 
Technical Overview

Pathways to PCDL 

• MassHunter Pathways to PCDL Software - Quick Start Guide

PCDL Manager 

• MassHunter Personal Compound Database and Library 
Manager - Quick Start Guide

• MS/MS Library Creation of Q-TOF LC/MS Data for 
MassHunter PCDL Manager - Quick Start Guide

Profinder 

• MassHunter Profinder Software - Quick Start Guide

• Agilent MassHunter Profinder: Solving the Challenge of 
Isotopologue Extraction for Qualitative Flux Analysis - 
Technical Overview
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Getting Started

How do I get started?
Getting Started

How do I get started?

This Quick Start Guide helps you install VistaFlux Software, 
review the software user interfaces, and perform basics tasks 
using the files found in the Data folder on the installation DVD.

Figure 3 Desktop icons for MassHunter VistaFlux Software: Pathways 
to PCDL, PCDL Manager, Profinder, and Omix Premium

1 Install the VistaFlux Software. Follow the instructions in 
“MassHunter VistaFlux Software Installation” on page 58.

2 Review the MassHunter VistaFlux Software - Workflow 
Guide.

3 Review the following sections in this Quick Start Guide:

“Software User Interfaces” on page 7

“MassHunter Pathways to PCDL” on page 7

“MassHunter PCDL Manager” on page 8

“MassHunter Profinder” on page 11

“Omix Premium” on page 18

“Definitions” on page 27

“Basic Qualitative Flux Analysis Workflow” on page 30

“What is Batch Isotopologue Extraction?” on page 54

4 Perform your qualitative flux analysis following the“Basic 
Qualitative Flux Analysis Workflow” on page 30.
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Software User Interfaces

MassHunter Pathways to PCDL
Software User Interfaces

A compound may be referred to as a feature, metabolite, 
molecular feature, element, or entity during the various steps of 
analysis using Agilent MassHunter software.

Help and detailed information regarding the various 
parameters and statistical treatments are available when you 
press F1 or click Help > Contents from the menu bar.

MassHunter Pathways to PCDL 

The main Pathways to PCDL window consists of two parts: the 
Menu Bar, and Display Pane. The window areas are shown in 
Figure 4.

1. Menu Bar

The menu bar (Figure 5 on page 8) provides actions that are 
used for finding pathways and creating a list of pathways from 
which compounds are extracted to create your PCDL.

Figure 4 The main functional areas of Pathways to PCDL
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Software User Interfaces

MassHunter PCDL Manager
Figure 5 Pathways to PCDL Menu bar

Settings Launches the Pathways to PCDL Settings dialog box where you 
can specify a reference METLIN database and choose whether 
to exclude compounds if the organism has no related enzymes 
when you are using the KEGG database.

Tools Provides options to update the local copy of pathway content 
culled from popular databases such as BioCyc/MetaCyc, KEGG, 
and WikiPathways. You can also import BioCyc tarball and zip 
files. Access to KEGG pathway content requires a separate 
license.

Help Provides a link to the MassHunter Pathways to PCDL Software 
- Quick Start Guide and information about the software 
version.

2. Display Pane

The Display Pane, see Figure 4 on page 7, is further divided 
into two panes — (1) Pathways or Compound List and (2) 
Selected Pathways List. The Display Pane helps you visualize 
your progress as you select pathways to create your PCDL. The 
number of pathways and compounds that meet your criteria are 
shown above each table in the Display Pane.

MassHunter PCDL Manager 

The main PCDL Manager window consists of five parts: Menu 
Bar, Toolbar, Action Tabs, Action Pane, and Compound Results. 
The number of compounds that meet your search criteria are 
shown above the table in the Compounds Results. The window 
areas are shown in Figure 6 on page 9.
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Software User Interfaces

MassHunter PCDL Manager
1. Menu Bar

The menu bar (Figure 7) provides actions that are used to 
create your custom PCDL.

Figure 7 PCDL Manager Menu bar

File Open, close, backup, and create new PCDLs. You can also create 
subset PCDLs, import compounds from another PCDL, and 
print and export your search results.

Edit Add, delete, save as, and update compounds in your PCDL. 
These commands are for use with custom PCDLs when (1) 
PCDL > Allow Editing is enabled and (2) the Edit Compounds 
tab is selected in the Action Pane.

Figure 6 The main functional areas of PCDL Manager
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Software User Interfaces

MassHunter PCDL Manager
View Manage the columns in the compound results table in the 
Compounds Results Pane and view the structure details in a 
larger Compound window.

PCDL Search for compounds and spectra in the open PCDL, toggle the 
Allow Editing mode, update your PCDL to the current version 
of PCDL Manager, and review information about your PCDL.

Links Open your default Internet browser to the selected database.

Help Provides a link to online Help and information about the 
software version.

2. Toolbar

The toolbar is located below the menu bar and contains three 
groups of buttons for commonly performed tasks:

PCDL Manager Toolbar

3. Action Tabs

The first four tabs (Single Search, Batch Search, Batch 
Summary, and Edit Compounds) provide options for you to 
search, view, and edit compounds in the open PCDL. The last 

Button Equivalent Command

PCDL > Find Compounds

File > Print Results

File > Export Results (from Batch Summary tab)

File > New PCDL

File > Open PCDL

Auto-size Columns, no equivalent command

Hide Empty Columns, no equivalent command

Help > Contents
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Software User Interfaces

MassHunter Profinder
three tabs (Spectral Search, Browse Spectra, and Edit Spectra) 
provide options for you to search, browse, and edit spectra in 
the open PCDL.

4. Action Pane

The Action Pane is where you enter and select parameters, 
information, and options, and then you view the compound and 
spectra results. Content of the Action Pane changes based on 
the tab selected.

5. Compound Results Pane

Lists the compounds that meet the search criteria. This pane is 
not available when you select the Spectral Search tab.

MassHunter Profinder 

The main Profinder window consists of three parts: (1) the 
Menu Bar, (2) the Toolbar, and (3) the Main Window. The main 
functional areas are shown in Figure 9 on page 12.

1. Menu Bar

The menu bar (Figure 8) provides actions that you use to 
manage your projects, methods, display, and extract features.

Figure 8 Profinder Menu bar

File Open, close, and save projects. You can also add or remove 
sample files from your project and export your results.

Edit Access to the Copy to Clipboard and Color by Sample Group 
operations.

View Show or hide the windows used to review the results from 
applying the feature extraction method to your data set (see “3. 
Main Window” on page 14).

Method Open and save your batch extraction methods.
VistaFlux Quick Start Guide 11



Software User Interfaces

MassHunter Profinder
Wizards Run one of the feature extraction algorithms. Each extraction 
algorithm is designed to efficiently extract the features 
(compounds) in your sample data files. Batch isotopologue 
extraction results are exported as a Profinder Archive (PFA) file 
and imported into Omix Premium as part of your qualitative 
flux analysis.

Configuration Launch the Plot Display Options dialog box where you can 
customize how chromatograms and spectra are displayed.

Help Provides a link to online Help and information about the 
software version.

2. Toolbar

The toolbar is located below the menu bar and contains five 
groups of buttons for commonly performed tasks:

Project New project, Open project, and Save project

Figure 9 The main functional areas of Profinder as viewed before you begin a project.
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Software User Interfaces

MassHunter Profinder
Samples Add sample files to your new or current project.

Main Window Display or hide the various tables and results generated by 
Profinder, so you can increase the available display area for 
your review.

Feature Coloring Toggle the feature coloring by sample group.

Extraction Select the feature selection algorithm you want to review, 
edit, and apply to your data set.

Results Modes Select the display mode to use in your results windows.

Profinder Toolbar Button Equivalent Command

File > New Project

File > Open Project

File > Save Project

File > Add/Remove Sample Files

View > Compound Groups

View > Compound Details

View > Chromatogram Results

View > MS Spectrum Results

View > Isotopologue Results

Edit > Color by Sample Group
VistaFlux Quick Start Guide 13



Software User Interfaces

MassHunter Profinder
3. Main Window

The main window, see Figure 9 on page 12, is further divided 
into up to five windows — (3a) Compound Groups, (3b) 
Compound Details, (3c) Chromatogram Results, (3d) MS 
Spectrum Results, and (3e) Isotopologue Results that are used 
to review the results from applying the feature extraction 
method to your data set. Each window can be floated 
independently to any location and size on your computer 
display or arranged to your preference within the main window. 
The various windows are described in the following paragraphs.

Wizards > Batch Molecular Feature Extraction

Wizards > Batch Recursive Feature Extraction

---------------- (small molecules / peptides)

Wizards > Batch Recursive Feature Extraction

-------------- (large molecules)

Wizards > Batch Target Feature Extraction

Wizards > Batch Isotopologue Extraction

List mode, no equivalent command

Sample group mode, no equivalent command

Overlaid mode, no equivalent command

Maximum number of chromatograms or spectra to 
display, no equivalent command

Configuration > Plot Display Options

Button Equivalent Command
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Software User Interfaces

MassHunter Profinder
Compound Groups The data presented in Compound Groups is 
organized as a list of all of your extracted feature data averaged 
and summarized across all of the data files in your project.

The Compound Groups window shows a table of 
compound-level information for each feature extracted from at 
least one data file, if the data was extracted using Batch 
Molecular Feature Extraction, or for all targeted features, if the 
data was extracted using Batch Targeted Feature Extraction or 
Batch Isotopologue Extraction. Measured information is shown 
as the average value for the feature across all of the files where 
the feature was found.

A compound group is a single compound (feature) found in any 
one or more of the data files in a project. For example, if the 
first data file in the project yields 35 compounds, then at least 
35 compound groups are in the project. If additional unique 
compounds are found in the other data files, then additional 
compound groups are created. 

Information regarding the available columns are found in the 
online Help in the topic “Compound Groups Columns.” A list of 
the available columns is displayed when you right-click within 
the Compound Groups table, and then click Add/Remove 
Columns.

Compound Details The data presented in Compound Details is 
organized as a list of the appearance of a selected feature 
(compound) in all of the data files in your project - feature 
information by data file.

The Compound Details window shows a table of compound-level 
information for a single feature selected in the Compound 
Groups window. The quantitative information is shown for the 
selected feature as it is found in each data file in your project.

Information regarding the available columns are found in the 
online Help “Compound Details Columns.” A list of the available 
columns is displayed when you right-click within the Compound 
Details table, and then click Add/Remove Columns.

See MassHunter Profinder Software - Quick Start Guide for an 
explanation of the symbols used in the Flags (Tgt) column.
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Software User Interfaces

MassHunter Profinder
Chromatogram Results Chromatogram Results presents the 
extracted ion chromatogram (EIC) for each feature and, for 
isotopologue extraction results, the sum of the EICs for all of 
the isotopologues. For non-targeted feature extraction, the 
extracted compound chromatogram (ECC) is displayed for the 
ions contained in the molecular feature of the feature selected 
in the Compound Groups window. An EIC/ECC set is displayed 
for each data file. By default the chromatograms are displayed 
in an alternating cycle of ten colors to help you review the data 
for a particular data file as you select different features. Color 
by Sample Group displays the samples in an alternating cycle 
of colors based on the sample group assignment.

MS Spectrum Results MS Spectrum Results presents the 
averaged mass spectrum (MS) across the integrated ECC for the 
feature selected in the Compound Groups window for each data 
file. For isotopologue extraction results the mass spectra are 
presented across the isotopologue extraction region. By default 
the MS is displayed in an alternating cycle of ten colors, 
matched with the Chromatogram Results, to help you review 
the MS data for a particular data file as you select different 
features. Color by Sample Group displays the samples in an 
alternating cycle of colors based on the sample group 
assignment.
16 VistaFlux Quick Start Guide



Software User Interfaces

MassHunter Profinder
Isotopologue Results Isotopologue Results presents a sequence 
of charts, or a single chart, depending on the results mode 
selected from the toolbar.

List mode displays the isotopologue results for each sample 
file. The isotopologue charts are arranged in the order of 
your sample groups with each sample replicate displayed in 
an alternating cycle of ten colors, matched with the 
Chromatogram Results and MS Spectrum Results. The 
coloring can be changed to represent the sample groups by 
selecting Color by Sample Group from the toolbar.

Sample group mode displays the isotopologue results for 
each sample group. Each sample replicate is displayed within 
each group chart in an alternating cycle of ten colors, 
matched with the Chromatogram Results and MS Spectrum 
Results. The coloring can be changed to represent the sample 
groups by selecting Color by Sample Group from the toolbar.

Overlaid mode displays a single summary chart of the 
isotopologue results. The summary chart contains the 
average and standard error for each isotopologue per sample 
group presented in gray scale. The sample groups can be 
viewed in color by selecting Color by Sample Group from the 
toolbar.

The order of the appearance of the samples and sample 
groups is set in the Add/Remove Sample Files dialog box. 
The compound containing the isotopologues is selected in the 
Compound Groups window.

The chart y-axes can be scaled to raw abundances (Raw), raw 
abundances normalized to 100% (Raw (%)), natural isotope 
abundance corrected abundances (Corrected), and natural 
isotope abundance corrected and normalized to 100% 
(Corrected (%)).

Raw: The actual abundances of each isotopologue by sample 
data file, or average abundance of each isotopologue when 
the data is viewed in the summary chart.

Corrected: The abundance for each isotopologue is corrected 
to remove the natural isotopic contributions so that the 
abundance is due to the isotopic enrichment from the 
qualitative flux analysis.
VistaFlux Quick Start Guide 17



Software User Interfaces

Omix Premium
Raw (%): The actual relative abundances of each 
isotopologue by sample data file, or average of each 
isotopologue when the data is viewed in the summary chart.

Corrected (%): The relative abundance for each isotopologue 
after the abundance for each isotopologue is corrected to 
remove the natural isotopic contributions so that the 
abundance is due to the isotopic enrichment from the 
qualitative flux analysis.

Unsaved parameter changes in Profinder

When you make a change to a parameter in Profinder, the 
software automatically places a change icon  (a blue triangle 
shape) in the wizard tab and next to the value containing the 
parameter where you made a change. This icon indicates that 
you have unsaved parameters changes and helps you remember 
to save the changes you have made to the method. To view the 
original parameter value, place your pointer over the change 
icon. When you save your method, the change icons disappear.

Omix Premium 

The main functional areas of Omix Premium are shown in 
Figure 10 on page 19. The main Omix Premium window consists 
of four parts: (1) the Menu Bar, (2) the Toolbar, (3) the 
Document Area, and (4) the Status bar. The document area can 
be further divided into up to five windows — (3a) Drawing Area, 
(3b) Component View window, (3c) Property Editor window, 
(3d) Data Manager window, and (3e) Log Messages window. 

Most of your interaction with Omix Premium takes place in the 
Drawing Area. Each window can be floated independently to 
any location and size on your computer display or arranged to 
your preference within the Document Area. 
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Software User Interfaces

Omix Premium
1. Menu Bar

The menu bar (Figure 11) provides actions that you use to 
create, edit, manage, view, and export your network diagram.

Figure 11 Omix Premium Menu bar (displayed in two rows)

Figure 10 The main functional areas of Omix Premium
VistaFlux Quick Start Guide 19
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Omix Premium
File Open, close, and create new network diagrams (documents). 
You can also import a network and export, print, and save 
images of your network diagram.

Edit Copy, cut, paste, undo, and redo operations related to the 
network diagram you create in the Drawing Area. Many of the 
operations in the Select toolbar are in this menu.

Insert Access to operations in the Edit and Graphics toolbars.

Layout Options to manage your network diagram layout.

Data Load your Profinder data, and open and close the Data 
Manager window.

Visualization Access visualization features of Omix Premium and operations 
related to the Agilent MassVisualizer plug-in.

View Zoom and enable layout feature in the Drawing Area and access 
to operations in the Visibility and Detail toolbar.

Analysis Access to network statistics and plug-in features related to 
13CFLUX2, atomic layer options, and chemical structure 
validity.

Extras Manage plug-ins available for Omix Premium, enable and 
disable document extensions, and launch the Omix Premium 
configuration dialog box.

Window Enable and disable any of the toolbars and switch between the 
windows associated with Omix Premium.

Help Provides a link to the Omix Visualization web site, update 
plug-ins, and information about the license and version.

2. Toolbars

There many toolbars that you can choose to show while using 
Omix Premium. Each toolbar is positioned below the menu bar 
along any side of the Drawing Area or each toolbar can be 
floated independently anywhere on your PC screen.

The commonly used toolbars are: Standard, Utility, Visibility 
and Detail, Zoom, Edit, Graphics, Select, and Agilent 
MassVisualizer. The default toolbar locations are shown in 
Figure 12 on page 21.
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Software User Interfaces

Omix Premium
Figure 12 Default toolbar locations around the Drawing Area

Omix Premium Toolbars Button Equivalent Command

Standard Toolbar

File > New > New Network

File > Open Network

File > Save

Edit > Search

Edit > Undo

Edit > Redo

Edit > Copy
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Software User Interfaces

Omix Premium
Edit > Cut

Edit > Paste

File > Import > Import Network from File

File > Export > Export Network File

File > Print

File > Save Image

Utility Toolbar

Visualization > Quick Visualizer

Visualization > Visualize by Scripting (OVL)

Layout > Edit Layout Patterns

Edit > Custom Shapes

Layout > Motif Stamps > Manage Motif Stamps

Extras > Document Extensions

Window > Sidebars > Component View

Window > Sidebars > Property Editor

Window > Sidebars > Log Messages

Window > Sidebars > Data Manager

Layout > Automatic Layout

Button Equivalent Command
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Software User Interfaces

Omix Premium
Visibility and Detail Toolbar

View > Show Rulers

View > Show Grid

View > Visualize Properties on Demand

View > Hide Metabolites

View > Hide Reactions

View > Hide Cofactors

View > Hide Effector Edges

View > Hide Flux edges

View > Hide Pathways

View > Hide Compartments

View > Hide Node Items

View > Hide Connection Edges

View > Hide Graphical Items

View > Appearance of Metabolite Labels

View > Appearance of reaction Labels

View > Appearance of Pathway Labels

View > Appearance of Compartment Labels

View > Appearance of Node Item Labels

Button Equivalent Command
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Software User Interfaces

Omix Premium
View > Hide Comments

View > Appearance of Reversibility

View > Hide Coefficients

View > Hide Item Accessories

Visualization > Visualize Chemical Structures

Zoom Toolbar

View > Zoom > Zoom 1:1

View > Zoom > Zoom In

View > Zoom > Zoom Out

View > Zoom > Zoom Selection

View > Zoom > Zoom Diagram

Edit Toolbar

Edit > Network View Mode

Edit > Select

Insert > Insert Metabolite > Insert Metabolite

Insert > Insert Reaction > Insert Reaction

Insert > Insert Flux Edge

Insert > Insert Effector Edge

Insert > Insert Pathway > Insert Pathway

Button Equivalent Command
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Software User Interfaces

Omix Premium
Insert > Insert Compartment > Insert Compartment

Graphics Toolbar

Insert > Insert Node Item

Insert > Insert Connection Edge

Insert > Insert Text Item

Insert > Insert Graphical Item

Insert > Insert Image

Insert > Insert Chart

Insert > Insert Comment

Select Toolbar

Edit > Delete

Edit > Group Items

Edit > Ungroup Items

Edit > Ungroup All

Edit > Mirror Horizontally

Edit > Mirror Vertically

Edit > Rotate 90° Clockwise

Edit > Rotate 90° Counter-Clockwise

Edit > Stack Before (applies to graphics items)

Button Equivalent Command
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Software User Interfaces

Omix Premium
Edit > Stack Behind (applies to graphics items)

Edit > Duplicate Metabolite Node

Edit > Invert Edge Direction

Edit > Invert Reaction

Add Spline Point, no equivalent command

Delete Spline Point, no equivalent command

Line, no equivalent command

Curve with one control point, no equivalent command

Curve with two control points, no equivalent command

Angular Join, no equivalent command

Axis Parallel Segments, no equivalent command

Smooth Join, no equivalent command

Symmetric Join, no equivalent command

Edit > Align with Grid

MassVisualizer Toolbar

Visualization > Agilent MassVisualizer > Show 

Abundance Changes

Visualization > Agilent MassVisualizer > Show Quilt 

Plots

Visualization > Agilent MassVisualizer > Show Bar 

Charts

Button Equivalent Command
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Definitions
3.Document Area

The Document Area is where you visually generate your 
network diagram, add representations of your qualitative flux 
analysis results, and generate report and presentation views. 
You can enable the Component View, Property Editor, Data 
Manager, and Log Messages windows to reside around the 
Drawing Area or float them anywhere on your PC desktop. the 
Drawing Area is replaced with the Pattern Editor when you 
add patterns to help align your network diagram.

4. Status Bar

The Status Bar shows the progress when you load and save 
network diagram documents. The Status Bar appears blank 
during most activities within Omix Premium.

Definitions

Algorithm An algorithm is a set of automated, sequential mathematical 
tasks performed to find, filter, align, and extract features from 
your chromatographic/mass spectral data sets.

Visualization > Agilent MassVisualizer > Show 

Background Information

Visualization > Agilent MassVisualizer > Reload 

Visualization

Visualization > Stop icon

Visualization > Back icon

Visualization > Play icon

Visualization > Slider bar

Visualization > Record icon

Button Equivalent Command
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Software User Interfaces

Definitions
Compound Group A single compound that is targeted, or found, in any of the 
sample data files in a project. For example, if 20 compounds are 
found in the first data file in the project, then there are at least 
20 compound groups in the project. If additional unique 
compounds are found in the remaining data files for your 
project, then additional compound groups are created.

Edge A visual representation of the connection between a reaction 
and a metabolite when creating a network diagram.

Feature A feature is synonymous with compound. A feature is referred 
to interchangeably with compound, metabolite, molecular 
feature, element, or entity during the various steps of analysis 
using Agilent MassHunter software.

Fold Change A measure of the amount of change expressed in the ratio of the 
amount of change from the original value versus the original 
value. A fold change can be positive (increasing) or negative 
(decreasing).

Sample Group An experimental condition, such as the time a sample was 
acquired after an experiment was started, assigned to replicate 
samples. Larger number of samples in a sample group improve 
the statistical significance of your qualitative flux analysis.

Isotopologue Molecules that contain the same molecular formula and 
structure but differ in their isotopic composition through the 
substitution of one or more atoms with a different isotope. The 
exact location of the isotope in the molecule, while important 
chemically, is not important in flux analysis, just the number of 
isotopes in the molecule.

Isotopomer Molecules that contain the same molecular formula, structure, 
and number of isotopes but differ in the specific atomic location 
of the isotopes in the molecular structure.

Labeling When an isotope of an atom is substituted for the naturally 
occurring atom, the resulting compound is referred to as being 
labeled. Metabolites in a cell can become labeled when a 
isotopically enriched compound is introduced to the cellular 
metabolism. An experiment that studies the rate that 
metabolites become labeled through metabolism are referred to 
as metabolic flux analysis or qualitative flux analysis.
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Definitions
Method A method is a set of parameters that are associated with the 
three feature extraction algorithms used by Profinder. Methods 
containing the parameters for the algorithms can be saved using 
unique file names.

Model Another name to refer to a network diagram.

Network A set of metabolite and reaction nodes that can be assembled 
with additional information to represent the operation 
biochemical system.

Network Diagram A graphical visualization of metabolite and reaction nodes, 
effectors, and flux edges that together represent the operation 
biochemical system.

Node A representation of a metabolite or reaction when you create a 
network diagram.

Pathway A sequence of reactions and metabolites that represent the 
chemical reactions that occur in a cell.

PCDL A personal compound database and library that contains 
necessary information compound information about your target 
metabolites; at a minimum the information must include 
identification, mass, and retention time.

Tracer A stable isotope labeled compound, referred to as a tracer, is 
introduced into the biological system for flux analysis. The 
tracer typically contains multiple atoms of 13C, 15N, or 2H.

Wizard A wizard is a sequence of interactive steps used by Agilent 
MassHunter software to guide you through the steps necessary 
to complete an analytical task. Profinder uses a set of wizards to 
guide you through the parameters associated with each feature 
extraction algorithm.

Workflow A workflow is an Agilent document or a graphical overview that 
captures a sequence of steps to guide you through an analytical 
task. A workflow may cover more than one wizard and may 
include steps performed by more than one software program.
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Definitions
Basic Qualitative Flux Analysis Workflow

The basic qualitative analysis workflow, illustrated in Figure 2 
on page 4, guides you through the steps necessary to identify 
target metabolites of interest for your experiment, create visual 
pathways networks for your experiment, acquire accurate mass 
data from your samples, extract accurate isotopic metabolite 
information from the sample data, and then view the results on 
network diagrams of the pathways involved in your experiment.

Pathways to PCDL

• “Create an initial PCDL from pathways content” on page 31

PCDL Manager

• “Generate a target metabolite PCDL” on page 34

Profinder

• “Create a Profinder Project” on page 39

• “Run Batch Isotopologue Extraction” on page 43

• “Create a Profinder Archive” on page 46

• “Save your Profinder project” on page 47

Omix Premium

• “Visualize your results in Omix Premium” on page 48
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Create an initial PCDL from pathways content

In this task, you launch Pathways to PCDL, select a pathway, 
and add the metabolites to an initial PCDL. A typical workflow 
using Pathways to PCDL is shown in Figure 13.

Figure 13 Typical Pathways to PCDL workflow

Steps Detailed Instructions Comments

1 Start Pathways to PCDL. • Double-click the Pathways to PCDL 
icon  located on your desktop, or 
click Start > All Programs > Agilent 

> MassHunter Workstation > 

Pathways to PCDL > Pathways to 

PCDL.

• The first time you run Pathways to 
PCDL you are prompted to set a 
reference METLIN database folder 
and filename. This is optional, you 
can click Cancel in the Select 

Reference METLIN PCD/PCDL 
dialog box.

2 Select the source to search for 
pathways data.

• Select BioCyc/MetaCyc for the 
Source under Pathway Data.

•

• The Pathways to PCDL converter 
supports pathway content from 
BioCyc/MetaCyc, KEGG, and 
WikiPathways databases. You must 
have a license, user name and 
password, to obtain content from 
the KEGG database.
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Create an initial PCDL from pathways content
3 Select an organism to filter the 
pathways from the data source.

• Select Homo sapiens from the 
Organism/Database list.

4 Choose a selection mode. • Click Pathway Names for the 
Selection Mode.

• The selection mode provides you 
with an option to select compounds 
(metabolites) for your PCDL by 
association with a pathway name, 
pathways that have a common 
compound name, and reactions that 
have a common compound name. 

5 Add one or more pathways to your 
Selected Pathways List.

a Type TCA for the Search Text.
b Click the row containing the TCA 

cycle pathway.
c Click Select Highlighted to move the 

pathway to the Selected Pathways 
List.

d Repeat steps a through c to continue 
adding pathways sources for your 
compound database if you are 
creating your own experiment.

• In cases when the number of 
pathways, or compounds, displayed 
in the Pathways or Compounds List 
in the display pane is large, you can 
reduce the number of pathways, or 
compounds, by using search text

• The compounds associated with 
the pathway are moved the 
Selected Pathways List 
immediately after you click Select 

Highlighted, or Select All.

•

Steps Detailed Instructions Comments
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Create an initial PCDL from pathways content
Your initial compound database is now created.

The next step is to review the initial PCDL and create your 
target metabolite PCDL.

6 Create your custom PCDL. a Click Create PCD/PCDL.
b Select the folder to save your 

PCD/PCDL database.
c Type the name for your PCD/PCDL 

database in File name, Target_01.
d Click Save.

•  Your PCDL is created from the 
compounds within the Selected 
Pathways List.

• The default folder for a custom 
PCDL is C:\MassHunter\PCDL.

e Click OK. • Summary information 
describing your custom PCDL is 
displayed after you Save the 
PCDL.

Steps Detailed Instructions Comments
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Generate a target metabolite PCDL

Generate a target list of metabolites of interest to your 
experiment using MassHunter PCDL Manager. In this step you 
edit the compound list in the initial PCDL you created using 
Pathways to PCDL. A typical workflow using Pathways to PCDL 
is shown in Figure 14.

Figure 14 Typical PCDL Manager workflow

Steps Detailed Instructions Comments

1 Start PCDL Manager. • Double-click the PCDL Manager icon 
 located on your desktop, or click 

Start > All Programs > Agilent > 

MassHunter Workstation > PCDL 

Manager.

• Edits made to your personal 
compound database are saved 
real-time to the open database and 
cannot be undone.

2 Make a copy of your personal 
compound database.

a Click File > New PCDL.
b Select General for Select the PCDL 

type.
c Type a new name for Enter the new 

PCDL name.
d Enter a useful description of the 

current PCDL for Enter a description 

of this PCDL.
e Click Create to make a copy of the 

compound database.

• The Create new PCDL dialog box 
immediately opens and has 
information completed for the open 
compound database.

• Creating frequent copies of your 
PCDL saves time returning to an 
earlier version of your target 
metabolite database.
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Generate a target metabolite PCDL
• When you create a new PCDL, the 
original PCDL is closed and the new 
PCDL is automatically opened in 
PCDL Manager.

• In the example, the original PCDL 
file name is appended with 
numbers “_xx” to simplify restoring 
a previous copy.

3 View the compounds in your 
personal compound database

a Click the Single Search tab.
b Click Find Compounds on the toolbar. 

• You must perform some type of 
search after you open your PCDL to 
view any, or all, of the compounds 
you created using Pathways to 
PCDL.

• Twenty compounds are in the 
BioCyc/MetaCyc, homo sapiens, 
TCA cycle pathway.

• If the compound database is large, 
searching the database without 
narrowing search criteria can take a 
long time.

Steps Detailed Instructions Comments
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Generate a target metabolite PCDL
4 Remove uninteresting compounds. a Click PCDL > Allow Editing to enable 
editing of the personal compound 
database. 

b Click the Edit Compounds tab.
c Click Hydrogen Ion in the Compounds 

Results Table.
d Shift-click Carbon dioxide in the 

Compounds Results Table to select 
the compounds between, and 
including, the selected compounds in 
the table.

e Click Delete Selected from the Edit 
actions.

• Since the databases created using 
Pathways to PCDL contain all of the 
compounds associated with the 
selected pathways, compounds 
that are not interesting your 
experiment can be removed.

• Compounds in the database can be 
added and removed using the Edit 
actions only when Allowing Editing 
is marked in the menu

• For the TCA cycle in the example, 
eleven compounds are interesting 
and nine compounds are removed.

• While all of the pathway 
compounds are metabolically 
significant, some are not 
observable, or observed based on 
the acquisition settings, in the 
mass spectrometer. For the 
example data set hydrogen ion, 
water, and carbon dioxide were 
both uninteresting target 
compounds and not visible in the 
mass spectrometer.

f Click Yes in the Delete Compound 
dialog box.

g Click the Single Search tab to refresh 
the search results value above the 
Compound Results Table.

h Click the Edit Compounds tab to 
return to editing the compounds.

i Repeat these steps to remove all of 
the uninteresting compounds from 
your PCDL.

• Reminder: Edits made to the 
compound database while 
Allowing Editing is enabled are 
saved real-time to your open 
database and cannot be undone.

• After you remove all of the 
uninteresting compounds you can 
make a new copy of your edited 
personal compound database.

Steps Detailed Instructions Comments
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Generate a target metabolite PCDL
5 Add a batch of new compounds 
from another PCDL.

a Click File > Open PCDL.
b Click the file name for the METLIN 

PCDL (or your own PCDL) in the Open 

PCDL dialog box.
c Click Open.
d Click the Batch Search tab.
e Enter the masses for the new 

compounds into the Masses table 
f Click Ignore for Retention times.
g Click Find Compounds on the toolbar

• While you can manually add new 
compounds to your compound 
database, a simple method is to 
append compounds to your 
compound database from another 
PCDL, such as from the Agilent 
METLIN PCDL.

• When the search is complete the 
results are displayed in the 
Compound Results Table. The 
compounds results are shown for a 
single mass at a time; the 
Compound Results Table is 
refreshed when you click on a mass 
in the Masses table in the Action 
Pane.

h Right-click the row containing the 
desired compound for the first mass in 
the Masses table.

i Click Append to PCDL.
j Select the compound database to add 

the selected compound for Select the 

PCDL to append to in the Append to 

PCDL dialog box.
k Click Append.

• For each mass you entered, PCDL 
Manager marks the row for the 
compound that is the best match 
for your search criteria. When the 
search criteria is minimal, the is 
compound is based on the 
Compound Name and CAS ID.

Steps Detailed Instructions Comments
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Your target metabolite database is now created.

l Click No in the Compounds Appended 

dialog box.
• Click No unless you are sure you 

want to close your current PCDL 
and open the target PCDL.

• When you click Yes in the 
Compounds Appended dialog box 
the target PCDL is opened and the 
current PCDL, along with your 
progress of adding compounds to 
the target PCDL, is closed.

m Click the next mass in the Masses 
table in the Action Pane.

n Repeat steps i through m for each 
mass.

o Click Yes in the Compounds Appended 
dialog box when you have appended 
the last compound to the target PCDL.

p Click the Single Search tab.
q Click Find Compounds on the toolbar 

to view the compounds in the target 
PCDL.

6 Add retention times and additional 
identifiers to your target 
metabolite list.

Note: The compounds in your target 
compound database for qualitative 
flux analysis must have retention 
times in order to perform the batch 
isotopologue extraction in 
Profinder.

a Click the Edit Compounds tab.
b Click PCDL > Allow Editing.
c Click on a compound row in the 

Compound Results Table. 
d Add retention times for each 

compound per your acquisition 
method development.

e Add any useful, additional compound 
information at this time.

f Click PCDL > Allow Editing to disable 
further editing.

• The compound highlighted in the 
Compound Results Table is the 
compound that is being edited in 
the Action Pane for the Edit 

Compounds tab.
• You can add retention times using a 

mass list file. See “Exercise 8. Add 
retention times to a PCDL” in the 
MassHunter Personal Compound 
Database and Library Manager - 
Quick Start Guide.

7 Save your target metabolite 
compound list.

• Click File > Exit to close PCDL 
Manager.

• All of the edits made while 
Allowing Editing is enabled are 
saved real-time to your open 
database; therefore you simply exit 
PCDL Manager to save your final 
target metabolite database.

Steps Detailed Instructions Comments
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Create a Profinder Project

In this task, you launch Profinder, select your sample files, and 
add the sample files to a new Profinder project. A typical Batch 
Isotopologue Extraction workflow using Profinder is shown in 
Figure 15.

Figure 15 A typical Profinder Batch Isotopologue Extraction workflow
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Create a Profinder Project
Steps Detailed Instructions Comments

1 Start Profinder. • Click the Profinder icon  on your 
desktop, or click Start > All Programs 

> Agilent > MassHunter Workstation 

> Profinder B.08.00.

• The first time you start Profinder it 
displays in full screen. Subsequent 
program launches remember the 
screen size from your prior session.

2 Begin your Profinder project by 
adding sample files.

• Click File > Add/Remove Sample 

Files, or click 
 on the 

toolbar.

• If you click File > New Project 
after starting Profinder, you are 
automatically prompted to add 
sample files.

• When you click Add/Remove 

Sample Files after launching 
Profinder, Profinder starts a new 
project as if you clicked File > New 

Project.

3 Add files to the Add Sample Files 

dialog box.
a Click Add file(s) to display the Open 

file dialog box.
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Create a Profinder Project
b Browse to the folder containing your 
sample files.

c Select all of the sample data files for 
your Profinder project.

d Click Open.

• Selected sample data files are 
highlighted in the Open file dialog 
box.

• A Profinder project contains all of 
the sample data files from your 
experiment - replicate samples for 
each condition (group) in your 
experiment.

• You can click Add Sample Files, to 
add additional sample data files to 
your project and rerun feature 
extraction.

4 Enter Sample Group values to the 
sample files in the Add Sample 

Files dialog box.

a Click the data entry cell under the 
Sample Group column, next to the 
sample file name.

b Enter the group identification text.
c Repeat for each sample file.

Steps Detailed Instructions Comments
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• When a data entry cell is selected it 
is highlighted using a background 
color.

• When you enter Sample Group 
names, the entries must use 
identical letters, numbers, 
punctuation, and case in order for 
the grouping functions to perform 
properly. 

• Use the Copy, Paste, and Fill Down 
shortcuts (click the right mouse 
button) to help assign Sample 

Group values to each sample.

5 Mark the samples to add to your 
project.

a Mark the samples to add to your 
project in the Show/Hide column.

b Click OK.

• All of the Samples in the same 
project must have the same 
polarity. If some of the Samples 
have a Positive Polarity and some 
have a Negative Polarity an error 
message is shown when you click 
OK.

• The Feature Extraction Workflow 
immediately prompts you to select 
a feature extraction algorithm. The 
next steps in this Quick Start Guide 
guides you through the steps to 
edit and run the Batch Isotopologue 
Extraction algorithm.

Steps Detailed Instructions Comments
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Run Batch Isotopologue Extraction

Batch Isotopologue Extraction supports only LC/MS acquired 
data. Batch isotopologue extraction anticipates that the target 
compounds may have undergone some degree of isotope 
labeling, to extract features from your sample data files. Batch 
Isotopologue Extraction is optimized to extract isotopologues 
for targeted features for qualitative flux analysis.

Steps Detailed Instructions Comments

1 Select the Batch Isotopologue 
Extraction workflow to apply to 
your samples.

a Click Batch Isotopologue Extraction.
b Click Next.

• Batch Isotopologue Extraction is 
optimal with data that has been 
acquired in profile mode and 
supports only LC/MS acquired 
data.

• Unlike the other batch feature 
extraction wizards, target retention 
times are required for this 
workflow.

2 Review and edit the parameters for 
the Batch Isotopologue Extraction 
algorithm.

a Click the Ion Species tab to make 
changes to the parameters associated 
with the charge carrier, charge state, 
and isotopic labeling.

b Click the Extraction tab to make 
changes to the parameters associated 
with the chromatographic and mass 
spectral extraction.

• Click Help to activate online Help 
specific for the current tab in the 
wizard.

• Click Cancel to stop editing the 
algorithm parameters. Any changes 
made to the algorithm parameters 
are not saved.

c Click the Ion Qualification tab to make 
changes to the parameters associated 
with feature matching, isotopologue 
thresholds, and coelution.
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3 Run the Batch Isotopologue 
Extraction algorithm.

a Click Finish to run the extraction 
algorithm on your sample data.

b An Operation in Progress dialog box 
is displayed while the extraction 
process is running.

• Click Cancel to stop editing the 
algorithm parameters. Any changes 
made to the algorithm parameters 
are not saved.

• The feature extraction process can 
take a long time. To significantly 
improve performance, use an SSD, 
increase the amount of RAM on 
your PC, and use a faster processor.

Steps Detailed Instructions Comments
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4 Review your results. • Review your results and then export 
the results and save your method.

• Using the Compound Groups, 
Compound Details, Chromatogram 
Results, MS Spectrum Results, and 
Isotopologue Results windows, you 
can edit your results: delete a 
compound group, delete abundance 
from compound details window or 
chromatogram results window, and 
integrate a peak manually. More 
information is available in the 
online Help.

• The next steps in this Quick Start 
Guide help you export your results 
and save your method.

Steps Detailed Instructions Comments
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Create a Profinder Archive

Save your Profinder results as a Profinder Archive (PFA) file to 
visualize your results in the context of biochemical networks in 
Omix Premium.

Steps Detailed Instructions Comments

1 Select Export as Profinder Archive 

from the File menu.
• Click File > Export as Profinder 

Archive.
• Alternate export options include:

• Export as CEF- features saved to 
a file format used to exchange 
data between Agilent software.

• Export as CSV - average Mass 
and RT with actual feature 
abundance for each sample

• Export as Detailed CSV - 
average Mass and RT with all 
actual feature values for each 
sample

2 Export your Profinder project as a 
PFA file.

a Click All compounds under Export 

contents.
b Enter your export destination folder, 

and enter your file name.
c Click OK.
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Save your Profinder project

Save your Profinder project, method, and the current sample 
data file extraction results so that you can continue reviewing 
your results and the extraction method at a later time.

You are now ready to view your results in Omix Premium.

Steps Detailed Instructions Comments

1 Select Save Project from the menu 
bar.

• Click File > Save Project. • If you have not previously saved 
your project, Save Project is the 
same as Save Project as and 
prompts you for a name to save 
your project.

2 Type the file name and save your 
project.

a Type the name to use for your project 
file in the Save as dialog box.

b Click Save.

• The Save As dialog box does not 
appear when you click Save Project 
if you previously saved your project.

• Click File > Save Project as if you 
want to save your project using a 
new file name.

• Note: Profinder project files can be 
one GB or more in file size.

• Note: Remember to include the 
original sample data when you 
share a Profinder project.
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Visualize your results in Omix Premium

In this task, you launch Omix Premium, open a template 
network diagram, import your Profinder results, and view the 
results in the context of your network diagram. 

The Agilent MassVisualizer plug-in provides you with the 
ability to visualize isotopologue data from Profinder; you can 
view absolute and relative abundances, labeling incorporation, 
and statistics within the context of your network diagram.

Steps Detailed Instructions Comments

1 Start Omix Premium. • Double-click the Omix Premium icon 
 located on your desktop, or click 

Start > All Programs > Omix 

Premium > Omix Premium.

2 Open the template network 
diagram.

a Click Open in the Document Area.
b Click Open other Document.
c Navigate to the folder containing the 

VistaFlux example data, then click the 
TCA-IDH2.omx template network 
diagram in the Open File dialog box.

d Click Open.

• When Omix Premium opens the 
document area is arranged to 
facilitate a quick means to review 
the software features, open a new 
document, and open a recent 
document.
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3 Import the example Profinder 
results. 

a Click Data > Open Data Table.
b Navigate to the folder containing the 

example data, then click the 
CS-Gln-IDH2.pfa Profinder Archive 
file in the Open Data Source dialog 
box.

c Click Open.

• Your target metabolites and 
isotopologue extraction results are 
imported into Omix Premium using 
a Profinder Archive (PFA) file, see 
“Create a Profinder Archive” on 
page 46.

4 Mark group 1 (0 Hr) as the control. • Double-click on the check box for 
group 1 under the Control column.

• The Data Manager window is 
opened along the bottom of the 
Display Area.

• If the Data Manager window is 
already open you can click the 
Open Data Table  button, a 
small button located at the 
bottom-left of the Data Manager 
window 

5 Close the Data manager window. • Click Data > Show Data Manager, or 
click the Data Manager  button on 
the toolbar, to close the Data Manager 
window.

• Click Data > Show Data Manager, 
or click the Data Manager  
button on the toolbar, to open and 
close the Data Manager window at 
any time.

Steps Detailed Instructions Comments
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6 Add visualization of abundance 
changes to your network diagram.

a Click the Show Abundance Changes 
 button from the toolbar, or click 

Visualization > Agilent 

MassVisualizer > Show Abundance 

Changes.
b Mark Show metabolite abundance 

fold change (vs. control).
c Mark Show labeling incorporation 

(ratio of labeled/unlabeled 
isotopologue abundances).

d Mark Show fractional labeling %.
e Click Individual sample group.
f Click OK.
g Adjust the parameters and become 

familiar with the results shown on the 
network diagram.

• Visualize up to three different 
summary statistics within the 
metabolite node:
• maximum metabolite abundance 

change per group versus the 
control

• label incorporation per group
• fractional labeling change per 

group versus control
• Abundance changes cannot be 

used with Draw structures on the 
metabolites. 

• Abundance change parameters are 
viewed in the Abundance Change 

Visualization dialog box.
• See the MassHunter VistaFlux 

Software - Workflow Guide for a 
detailed overview of the Abundance 
Change Visualization.

Steps Detailed Instructions Comments
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7 Add visualization of quilt plots to 
your network diagram.

a Click the Show Quilt Plots  button 
from the toolbar, or click Visualization 

> Agilent MassVisualizer > Show 

Quilt Plots.
b Mark Show quilt plots of 

isotopologue abundance.
c Click Individual sample group.
d Click OK.
e Adjust the parameters and become 

familiar with the results shown on the 
network diagram.

• Visualize the isotopologue 
abundances, by individual or all 
sample groups, in quilt plots next to 
the metabolite nodes.

• Indications of statistical 
significance of the isotopologue 
abundances among the groups can 
be enabled and adjusted by either a 
pairwise Welch’s t-test versus 
control or a one-way ANOVA of 
each group against every other 
group.

• Quilt plot parameters are viewed in 
the Quilt Plots dialog box.

• See the MassHunter VistaFlux 
Software - Workflow Guide for a 
detailed overview of the Quilt Plots.

Steps Detailed Instructions Comments
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8 Add visualization of bar charts to 
your network diagram.

• You can view bar charts containing:
• metabolite abundance
• label incorporation
• fractional labeling
• isotopologue histograms

a Click the Show Bar Charts  button 
from the toolbar, or click Visualization 

> Agilent MassVisualizer > Show 

Bar Charts.
b Mark Show bar charts.
c Click Individual sample group.
d Click OK.
e Adjust the parameters and become 

familiar with the results shown on the 
network diagram.

• Visualize various isotopologue 
summaries in bar charts displayed 
next to the metabolite nodes.

• Bar chart parameters are viewed in 
the Bar Charts dialog box. The 
dialog box parameters are identical 
for Metabolite abundance and 
Fractional labeling.

• See the MassHunter VistaFlux 
Software - Workflow Guide for a 
detailed overview of the Bar Charts.

Steps Detailed Instructions Comments
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9 Save your Omix Premium project. a Click File > Save As.
b Navigate to the folder to save your 

Omix Premium network in the Save 

Omix Network Model dialog box.
c Enter a descriptive name for the File 

name.
d Click Save.

• At any time during your session 
with Omix Premium you can save 
your pathways network diagram as 
an Omix Premium (OMX) 
document. Save your session with 
a descriptive name and a sequential 
number for the file name to save 
time when you return to prior 
network diagram.

• When your Omix Premium 
document has unsaved changes an 
asterisk appears at the end of the 
file name in the title bar

Steps Detailed Instructions Comments
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What is Batch Isotopologue Extraction?

Batch isotopologue extraction is optimal with data that has 
been acquired in profile mode GC/Q-TOF and GC/MSD is not 
supported by batch isotopologue extraction. Unlike the other 
batch feature extraction wizards, target retention times are 
required for this workflow. 

Isotopologue extraction uses an input CSV file or compound 
database file, PCD/PCDL, containing the target feature 
molecular formulas, mass, and/or retention time information, 
and anticipates that the target compound may have undergone 
some degree of isotope labeling. After feature extraction is 
performed, the extraction algorithm determines which of the 
possible isotopologues are actually present, measures the raw 
abundances of the isotopologues, and corrects the 
isotopologues abundances for the natural occurrence of the 
unlabeled ions. 

Isotopes, Isotopomers, Isotopologues, and Mass Spectra

Isotopologues are molecules that contain the same molecular 
formula and structure but differ in their isotopic composition 
through the substitution of one or more atoms with a different 
isotope. The exact location of the isotope in the molecule, while 
important chemically, is not important in flux analysis, just the 
number of isotopes in the molecule. Isotopologues can be 
identified using single-stage MS.

Isotopomers are molecules that contain the same molecular 
formula, structure, and number of isotopes but differ in the 
location of the isotopes in the molecular structure. Isotopomers 
can be identified using advanced MS/MS techniques.

Note: Profinder finds and extracts isotopologues in your sample 
data; it does not find or extract isotopomers. 
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Figure 16 An illustration of how two stable carbon isotopes in a 
four-carbon molecule relate to isotopomers and isotopo-
logues. Isotopologues are viewed in mass spectra during flux 
analyses. 

A simple four carbon molecule, fumaric acid (C4H4O4), is used 
to explain the relationship of isotopes to isotopomers, 
isotopologues, and mass spectra. The most abundant isotope of 
carbon is 12C. However, 13C, also stable, is not nearly as 
naturally abundant as 12C; 13C has a natural occurrence of 1.1% 
of 12C. For simplicity, naturally occurring 13C is considered to 
be negligible; therefore, the mass of the naturally occurring 
four-12C molecule is m (represented as 12C4), and there are no 
positional differences among the isotopes of the carbon atoms.

When a single 13C atom is substituted for one 12C atom, four 
locations are possible where the 13C atom can be placed 
(isotopomers as shown in Figure 16), and each isotopomer has a 
mass of m + 1 (12C3

13C). When two of the 12C atoms are 
replaced with 13C atoms, six isotopomers are possible, and each 
of the doubly substituted molecules has a mass of m + 2 
(12C2

13C2). When three of the 12C atoms are replaced with 13C 
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atoms, four isotopomers are possible, and each isotopomer has 
a mass of m + 3 (12C 

13C3). Finally, when all four of the 12C 
atoms are replaced with 13C atoms, only a single arrangement 
with a mass of m + 4 (13C4) exists. The five different masses m, 
m + 1, m + 2, m + 3, and m + 4 represent the masses of the five 
isotopologues visible in the resulting mass spectra.

Isotopologue mining

Profinder performs isotopologue mining in two stages, an initial 
screening followed by refinement. The initial screening stage 
extracts isotopologue EICs around the target retention time 
range and then evaluates peak mass spectral data to find ions 
that match the predicted list of possible isotopologues. The 
refinement stage uses a self-optimizing peak finder to refine the 
m/z assignment from the profile data and then re-extracts the 
EICs using the new isotopologue m/z values, refines the start 
and end retention time bounds on the newly extracted EICs, 
and then reports both EIC peak area and summed isotopologue 
peak heights as the compound abundances.
56 VistaFlux Quick Start Guide



What is label incorporation?

Visualize your results in Omix Premium
What is label incorporation?

A feature in Omix Premium is to display label incorporation (L) 
for your target metabolites. The label incorporation for each 
metabolite is the sum of all non-zero isotopologue abundances 
divided by the m+0 isotopologue abundance as shown by the 
following equation:

 

where m represents the non-labeled target metabolite, n is an 
integer representing the maximum number of labeled atoms 
observed in the target metabolite, and A is the abundance of the 
indicated metabolite isotopologue.

When label incorporation is visualized for a single sample 
group, the minimum and maximum label incorporations, Lmin 
and Lmax, are searched within the current sample group.

Only those metabolites are considered that are not on the 
ignore list. When L=0 the metabolite is additionally ignored 
because L=0 has a special color; therefore, Lmin is always > 0. 
Lmin and Lmax are then scaled to values between 0 and 1 for 
color coding. When L of an ignored metabolite is 0 < L < Lmin it 
is scaled to 0, when L > Lmax it is scaled to 1. All other L values 
scaled between 0 and 1.

In the default color coding, from white to dark green, the 
whitest metabolite is L = Lmin and the most dark green colored 
metabolite is L = Lmax. If a metabolite has no label 
incorporation (L=0) the no-fold-change color is taken.

When label incorporation is visualized for all sample groups, 
the greatest label incorporation value out of all of the sample 
groups is assigned for each individual metabolite. Then, the 
same scaling is applied as described for a single sample group.

L
Am n+

Am 0+
-----------------

1

n

=
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MassHunter VistaFlux Software Installation

MassHunter VistaFlux Software 1.0 contains the following 
components on the installation DVD:

Agilent MassHunter Pathways to PCDL Software B.07.00

Agilent MassHunter PCDL Manager B.07.00 SP2

Agilent MassHunter Profinder B.08.00

Omix Premium Version 1.9

Data folder containing example data and project files:

CS Gln Flux - data folder containing 15 sample data files

Profinder-Gln-IDH2.m - Profinder method folder

BioCyc metabolites.cdb - PCDL for the example data

CS-Gln-IDH2.pfa - Profinder archive file

CS-Gln-IDH2.Profinder - Profinder project file

TCA-IDH2.omx - Omix Premium project file

TCA-BioCyc-IDH2.cdb - metabolite compound database

Install MassHunter VistaFlux Software on the highest 
performing PC you have available. Profinder requires a PC 
running Windows 7 (64-bit) with at least 8GB of RAM and at 
least 30GB of available disk space.

Note: A PC with 16GB or more of RAM and a solid-state drive 
has significantly improved Profinder performance and 
reduction in the time it takes to extract features from large data 
sets.

Pathways to PCDL, Version B.07.00 

Pathways to PCDL is installed from a Setup Wizard, which you 
run from the main installation program.

Double-click Pathways to PCDL.msi, or right-click the file and 
then click Install.
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PCDL Manager, Version B.07.00 SP2 

PCDL Manager is installed from a Setup Wizard, which you run 
from the main installation program. After you install version 
B.07.00, follow the instructions to install service packs SP1 and 
SP2.

Right-click PCDLSetup.exe, and then click Run as 
administrator.

Install SP1 1 Navigate to the folder Service Packs\SP1 on the installation 
DVD.

2 Right-click PCDL.B.07.00.SP1.exe, and then click Run as 
administrator.

Install SP2. 1 Navigate to the folder Service Packs\SP2 on the installation 
DVD.

2 Right-click PCDL.B.07.00.SP1.exe, and then click Run as 
administrator.

Profinder, Version B.08.00 

Profinder is installed from a Setup Wizard, which you run from 
the main installation program. If you have a prior version, 
uninstall Profinder before installing this newer version (see 
“Uninstall a prior version of Profinder” on page 59).

Right-click ProfinderSetup.exe, and then click Run as 
administrator.

Uninstall a prior version of Profinder If you have a prior version 
of Profinder installed, you must remove the prior version before 
installing a newer version.

1 Click Start > Control Panel.

2 Click Programs and Features.

3 Click Agilent MassHunter Workstation Profinder 
Software.

4 Click Uninstall/Change to uninstall Profinder.
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Omix Premium, Version 1.9 

Omix Premium is installed from a Setup Wizard, which you run 
from the main installation program. 

When you start Omix Premium for the first time, you need an 
Internet connection and you are requested to activate the 
installation with a serial number. 

1 Right-click OmixPremium1.9.exe, and then click Run as 
administrator.

2 Launch Omix Premium and activate your installation with 
your serial number.

Note: The Omix Premium serial number is located on the 
sleeve containing your MassHunter VistaFlux Software DVD.

a Double-click the Omix Premium icon  located on your 
desktop, or click Start > All Programs > Omix Premium > 
Omix Premium.

b Type your serial number.

c Click Activate. You must have an Internet connection to 
activate Omix Premium.

d Click Close.

3 Optional, register your serial number by visiting 
http://premium.omix.bio/registerserialnumber.

Note: After you register Omix Premium you can manage your 
serial number and activations in your user account. Every 
serial number includes activations on three different 
computers. You can remove a computer from the list of 
installations every six months and use the available 
activation for a new computer, this helps you move Omix 
Premium to newer computer hardware and manage users in 
your laboratory.
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BioCyc Pathway/Genome Databases

Includes BioCyc Pathway/Genome 
databases from the Bioinformatics 
Research Group at SRI International®, 
used under license.

http://www.biocyc.org/

Citation based on use of BioCyc databases or the Pathway Tools 

software

If you use BioCyc databases or the Pathway Tools software in your 
research, cite relevant publications as described on the BioCyc 
website:

http://biocyc.org/publications.shtml

For example, users who publish research results in scientific 
journals based on use of data from the EcoCyc 
Pathway/Genome database should cite:

Keseler et al., Nucleic Acids Research 39:D583-90, 2011. 

Users who publish research results in scientific journals based 
on use of data from most other BioCyc Pathway/Genome 
databases should cite:

Caspi et al., Nucleic Acids Research 40:D742-53, 2012.

KEGG Database

Includes KEGG (Kyoto Encyclopedia of 
Genes and Genomes) databases developed 
by Kanehisa Laboratories.

http://www.genome.jp/kegg/

Citation based on use of KEGG Database

If you use the KEGG database in your research, cite relevant 
publications as described on the KEGG website:

http://www.genome.jp/kegg/kegg1.html
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