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This Quick Start Guide provides an overview of how to use the Feature 
Extraction 12.2 software. Step- by- step instructions are given for how to 
start the software and run an extraction.

This guide assumes that you have already installed Feature Extraction 12.2 
and its license on your computer. For information on how to install 
Feature Extraction 12.2, see the Feature Extraction Installation Guide.

For a complete description of the Feature Extraction main window and its 
components, see the Feature Extraction 12.2 Users Guide.
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What Is Agilent Feature Extraction Software?
What Is Agilent Feature Extraction Software?

Agilent Feature Extraction 12.2 software automatically reads and processes 
up to 100 raw microarray image files in the batch mode. Real- time 
extraction occurs as soon as the Agilent scanner produces a TIFF image. 
The software finds and adjusts microarray grids, rejects outlier pixels, 
accurately calculates feature intensities and ratios, flags outlier features, 
and calculates statistical confidences. Application- specific QC reports 
summarize multiple analyses. 

Agilent Feature Extraction software extracts data from microarray images 
produced in the following different situations:

• Agilent microarrays scanned on an Agilent scanner

• Non- Agilent microarrays scanned on an Agilent scanner

• Agilent microarrays scanned on a supported non- Agilent scanner (i.e. 
Roche NimbleGen MS 200 scanners, Molecular Devices GenePix 
scanners, select Innopsys InnoScan scanners, and select Tecan scanners)

Feature Extraction handles each of these images differently. These 
differences are described throughout the documentation.

If you are a new user
Read “Getting Help” on page 4 and “Starting the Software and Setting up 
eArray” on page 7.

If you intend to analyze...

• Saved images (Agilent or non- Agilent), read the “Instructional overview” 
on page 14.

• Agilent images in real- time, read the “Instructional overview” on 
page 25, and go to “General Instructions” on page 26.

If you are an experienced user
Read “What’s New in Version 12.2?” on page 6.
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To download updates manually
To download updates manually
When Feature Extraction is installed, Feature Extraction protocols and QC 
metric sets are also installed. Grid templates are not included with the 
installation. If you set up an eArray login, the software automatically 
downloads and updates the necessary grid templates and Feature 
Extraction protocols from the eArray server. You can also go to the 
following websites to download updates manually.

The following are some useful Agilent websites: 

https://earray.chem.agilent.com/earray - To register for eArray account

www.agilent.com/genomics/suredesign - To register for a SureDesign 
account

www.agilent.com/en/download- protocols- feature- extraction- software- To 
download Feature Extraction protocols

www.agilent.com/chem/designfile - To download grid templates

www.agilent.com/en/qc- chart- tool- metric- sets - To download QC metric 
sets
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Getting Help
Getting Help

To get help for Feature Extraction
The following table lists the resources available in the Help menu on the 
Feature Extraction menu bar. Guides are in PDF format, and require a 
PDF viewer such as Adobe Reader. 

Help Resource Description/Instructions

Feature Extraction Quick Start 

Guide

This guide, which you are reading, gives you an overview of the 

Feature Extraction software. To open this guide from within 

Feature Extraction, click Help > Quick Start Guide.

Feature Extraction User Guide A comprehensive guide for using the Feature Extraction software, 

that includes the following chapters:

• Chapter 1– Working with Feature Extraction

• Chapter 2– Extracting Microarrays Automatically

• Chapter 3– Creating Grid Files and Templates

• Chapter 4– Changing Protocol Settings

• Chapter 5– Changing Image Displays

To open this guide from within Feature Extraction, click Help > 
User Guide.

Feature Extraction Reference 

Guide

A reference guide that contains information about protocols, QC 

reports, results, and algorithms, that includes the following 

chapters:

• Chapter 1 – Default Protocol Settings

• Chapter 2 – QC Report Results

• Chapter 3 – Text File Parameters and Results

• Chapter 4 – MAGE-ML Results

• Chapter 5 – How Algorithms Calculate Results

• Chapter 6 – Command Line Feature Extraction

To open this guide from within Feature Extraction, click Help > 
Reference Guide.

Technical Support Opens a link to the Agilent Technical Support website. Here, you 

can find literature and manuals, view Frequently Asked Questions, 

and download updates and revision information. There is also a 

Contact Us link where you can locate the technical support phone 

number or send an e-mail message to technical support for your 

country.
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To learn about Agilent products and services
To learn about Agilent products and services
To view information about the Genomics products and services that are 
available from Agilent, go to www.agilent.com.

Feature Extraction Training Opens a link to the Feature Extraction Tutorials website, where you 

can view a number of self paced instructional tutorials.

To open this website from within Feature Extraction, click Help > 
Feature Extraction Training.

Feature Extraction on the Web Opens a menu that provides links to the following:

• Array annotation – Find available design files by barcode

• Feature Extraction Software – Feature Extraction software 

downloads and information

• Feature Extraction Protocols – Download current and previous 

versions of Feature Extraction protocols

Agilent License Opens the Agilent software license redemption website, where 

you use your entitlement certificate to redeem your software 

license.

Memory Status Opens an information window that shows how much computer 

memory is currently available and how much memory is in use.

About Opens an information window that shows your Feature Extraction 

version, license, and database information. This window also 

displays your computer Host ID. To redeem your license, you need 

your Host ID.

Help Resource Description/Instructions
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What’s New in Version 12.2?
What’s New in Version 12.2? 

Feature Extraction 12.2 includes an optional enhanced algorithm for spot 
finding in Agilent CGH array images. When the option is enabled, Feature 
Extraction increases the area around the expected spot center in which 
the spot finding algorithm looks for pixels that make up the spot. If the 
increased search area captures pixels from neighboring spots, then the 
algorithm does not attribute those pixels to the spot. This enhancement 
may provide more accurate placement of the center of each spot and more 
accurate identification of the pixels attributed to each spot, leading to 
fewer non- uniform features in the image, particularly for larger arrays. 

See the Feature Extraction 12.2 Reference Guide for information on the 
use of the enhanced spot finding algorithm in custom CGH protocols. The 
previous spot finding algorithm is still available and continues to be used 
in the default CGH protocol in Feature Extraction 12.2. See the Feature 
Extraction 12.2 User Guide for instructions on enabling or disabling the 
spot finding enhancement in your own imported or custom protocols. 
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Starting the Software and Setting up eArray
Starting the Software and Setting up eArray

To start the software from Windows
• Double- click the Feature Extraction shortcut on your desktop. 

This shortcut was created when the Feature Extraction software was 
installed.

OR

• From Windows, click Start > All Programs > Agilent Feature 
Extraction 12.2.x.x > Agilent Feature Extraction 12.2.x.x.

To set up a Feature Extraction license

Redeem your software licenses

To obtain your Feature Extraction license:

1 Start the Feature Extraction software and select Help > Agilent 
License.

Have the following items available:

• Software Entitlement Certificate (SEC) - This PDF contains the 
Order Number and Certificate Number that you provide to redeem 
your purchased license.

• Host ID - This ID can be found under the menu Help > About. You 
provide the host ID to redeem your purchased license.

2 Follow the instructions on the Agilent Software License Redemption 
website to redeem your purchased license.

After redeeming the license online, you will receive an e- mail message 
with the license attached.

Save the unzipped license file to the folder on the drive where you 
installed the software. 

NOTE To use Feature Extraction, install a valid license. If you do not have a license installed, you 

see a message.
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To set up eArray login
Set up the license from Feature Extraction

1 Start the Feature Extraction software, if it is not already running.

If the Feature Extraction software is already running (unlicensed), click 
the New Project icon. 

2 A message appears that informs you that you do not have a valid 
license installed. Click Retry.

The Select Agilent Feature Extraction License File dialog box opens.

3 Find the folder that contains the license file.

4 Select the license file (.lic), and click Open.

To set up eArray login
When you first open Feature Extraction, the eArray Login Setting window 
appears on top of the Feature Extraction main window. If you do not see 
the eArray Login Setting window, you can access it using Tools > eArray 
settings.

Figure 1 eArray Login Setting dialog box
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To set up eArray login
Feature Extraction connects to the Agilent eArray server automatically. It 
downloads, installs, and uses the required grid templates, Feature 
Extraction protocols, and QC metric sets during extraction.

It is highly recommended that you set up an eArray login to take 
advantage of this feature before you run the extraction project. 

1 Type your eArray User Name and Password in the eArray Login 
Setting window, if you already have an existing eArray account. Tip: 
The user name is the e- mail address you provided when you created an 
eArray account.

If you do not have an eArray account, first register for one. To start the 
registration process, click Register. This link opens the Agilent eArray 
registration website where you can request a free eArray account. 
Follow the instructions provided on the eArray website to complete the 
registration.

2 Click Test Connection. The message “Login Successful!!!” is displayed if 
the connection to the eArray server is successful. If you get the message 
“Login denied”, check that the user name and password you typed are 
correct.

3 Under Advanced Options, select the appropriate boxes:

• Use eArray server during extraction

Select this check box to log in to the eArray server. Feature Extraction 
downloads, install, and use grid templates (design files), Feature 
Extraction protocols, and QC metric sets automatically during 
extraction.

• Check for updates of grid template

Select this check box to download updates to existing grid templates 
already in the Grid Template Browser. Updated grid templates are 
added to the database, leaving existing grid templates, unless you mark 
Replace old grid template. When selected, the newest grid template in 
the database is used for feature extraction.

NOTE To log in to eArray, an internet connection is required.
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To set up eArray login
If several versions of a design are in the database and you want to do 
an extraction using an older design, clear this box. Otherwise, the 
extraction automatically uses the most recent version of the design 
(whether you are using the eArray server during extraction or not.)

• Replace old grid template

When you select this check box, Feature Extraction replaces old grid 
templates in the Grid Template Browser with the latest ones from the 
eArray server.

• On starting Feature Extraction check for protocol update from 
eArray server

Select this box to download updates from the eArray server for existing 
default protocols and QC metric sets in the FE Protocol Browser. 

4 To save the eArray login settings, click Save. You see a message “Setting 
updated successfully”. Click OK to close the message, and click Close to 
exit the eArray Login Setting window.

Now you see the Feature Extraction main window.
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To set up eArray login
Figure 2 Feature Extraction Main Window
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To open an image file
To open an image file
1 With the Feature Extraction main window open, click File > Open > 

Image, and browse to the folder that contains the image file. 
Double- click the image file (.tif) that you want to open. 

If the Feature Extraction software is running, you can also “drag and 
drop” the image from your folder to the open Feature Extraction 
window.

If you do not have the Feature Extraction software running, you can 
also open an image file by dragging and dropping an image file to the 
Feature Extraction shortcut on your desktop.

Figure 3 Feature Extraction main window with open image

Image Toolbar

IMAGE WORK WINDOW
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To open an image file
To learn more about interactively finding spots and creating grid files for 
non- Agilent images, see Chapter 3, “Creating Grid Files”, in the Feature 
Extraction 12.2 User Guide.

To learn more about changing the image display, see Chapter 5, “Changing 
Image Displays”, in the Feature Extraction 12.2 User Guide.

NOTE For high-resolution images (2- or 3-micron or 20-bit), you see a low-resolution preview 

image until you crop to roughly 1/10 of the preview image size. Then you see the original 

high-resolution image. [The Crop Cursor turns red when you are outside the high-resolution 

(High Fidelity) region.]
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Setting up a Standard Project to Extract Agilent and Non-Agilent Image Files
Setting up a Standard Project to Extract Agilent and Non-Agilent Image 
Files

Instructional overview
Follow the road map shown here and the instructions on the next pages 
to get started.

See Chapter 2 in the Feature Extraction 12.2 User Guide for details on 
this task.

The Agilent Feature Extraction software works with Agilent or non- Agilent 
microarray images produced on Agilent scanners using projects, extraction 
sets, grid templates or files, and protocols. The images are organized into 
extraction sets that contain the grid and protocol information to run the 
extraction. The extraction sets, in turn, are organized into projects. Note 
that for non- Agilent images, the program converts the images when they 
are added to an extraction set.

Start 
Here!

Set up and 
run saved 
image files

Add image files 
(extraction sets)

Create a 
“Standard 
Project”

Enter project 
properties

Check extraction 
configuration 
and save project

Add/change 
grid files/ 
templates 
(optional)

Run the 
extraction sets 
in the project

Add/change 
protocols 
(optional)
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Instructional overview
Figure 4 Project Explorer with expanded extraction sets

project A grouping of information that contains one or more extraction sets that 
define the files to use in the extraction.

extraction set Each group that contains a microarray image file, grid template (or grid 
file) and protocol within a project. This term is used both before and after 
extraction.

grid template Grid information from Agilent design files or grid files stored in the 
database. A grid template includes feature annotation and general 
geometry about the microarray (number of rows, columns, subgrids, 
feature spacings), used to find spots before data analysis takes place. 
Although not specific to any microarray image, grid template information 
is usually applied to the image for which the template was designed.

grid file Grid files are required to do feature extraction for non- Agilent images. 
Rarely, the automatic grid placement of Agilent images using a grid 
template produces an incorrect grid. If this happens, supply a 
user- generated grid file. When using a grid file, extraction uses the 
nominal and “found” spot locations specific to the image from which the 
grid file was created. Grid files are created in the Feature Extraction 
program using a microarray image file and a microarray layout file (such 
as an Agilent Design file or a .GAL [GenePix Array List] file). If the 
“Calculate spot size and centroids” option is run before the file is saved, 
the grid file contains the locations of the “found” spots. You can create 
grid templates from grid files, although the templates have only geometry 
information, no found spots.

protocol A list of steps and parameter values that define the data analysis 
algorithms and calculations used for feature extraction of a microarray 
image or images.

Extraction Set

Image File

Grid Template (design)

Protocol

Grid File
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General instructions
General instructions

Step 1. Create a Standard Project

• If the Feature Extraction software is not already running, start the 
program from your desktop or from the Windows Start menu.

Feature Extraction automatically creates a standard project 
(FE_Project1) every time you start the program. The Feature Extraction 
main window appears with the Project1 work window and an empty 
Extraction Set Configuration tab window. 

Figure 5 Feature Extraction main window 

Standard Toolbar

Grid Template 
Browser Pane

FE Protocol 
Browser Pane

Project Explorer 
Pane

QC Metric Set 
Browser Pane

PROJECT WORK WINDOW

FE Project Tools
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General instructions
You can change where and how the project work window and the 
browser panes dock when you start the program. To learn more about 
working with this interface, see the Feature Extraction 12.2 User 
Guide. 

Step 2. Enter the project properties

1 Click the Project Properties tab to view the default project properties.

2 To change a default setting, select a property and click the down arrow 
that appears on the right column. Choose from the available options.

Figure 6 Default project properties for a standard project

You can run Feature Extraction for one or more Agilent images generated 
by the Agilent scanner with these default project properties. You can also 
set up and run multiple extractions with a combination of Agilent and 
non- Agilent images.
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General instructions
Step 3. Add image files (extraction sets) to the project

1 In the Project Explorer, right- click FE_Project1, and click Add 
Extraction.

2 Select one or more images, and click Open. 

• To select multiple images at a time, hold down the Ctrl key and select 
the images.

• You can also add one or more image files by dragging and dropping 
them from the folder to the open project in the Feature Extraction 
window.

The selected images open in Feature Extraction. Note that for 
NimbleGen, GenePix, Innopsys, and Tecan images, the program first 
converts the images and then the converted images open in Feature 
Extraction. 

Any extraction set that is missing the required components, such as grid 
template or protocol, shows a lightning bolt in Project Explorer and a “?” 
in the icon of the missing component. (Provided eArray is enabled and the 
image is an Agilent image.) In versions prior to 10.5, if any of the 
required components are not attached to the TIFF image, the extraction 
set is not extracted. This changed beginning with version 10.5. 

You do not need to assign a grid template/grid file and a protocol to an 
image file to run the extraction. Extraction sets without a grid template 
and/or a protocol attached to the project can be extracted, by setting the 
software to automatically determine the correct template and protocol to 
use. For this functionality to work, verify:

• Before running the extraction, you set up to use the eArray server 
during extraction, as discussed in the section “To set up eArray login” 
on page 8.

OR

• Before running the extraction, the required grid templates and protocols 
exist in the database and are shown in the Grid Template Browser and 
FE Protocol Browser.

For custom grid templates and protocols that cannot be found on the 
eArray server, add them manually to the database before you run the 
extraction. See the Feature Extraction 12.2 User Guide.
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If grid templates are not loaded automatically, or you want to use a 
different grid template or protocol, you can assign them manually. See 
“Step 4. Assign grid template/grid file to the extraction set (depending on 
type of images)” on page 19 and “Step 5. Assign a protocol to the 
extraction set (optional)” on page 21.

Step 4. Assign grid template/grid file to the extraction set (depending on type of 
images)

Agilent images By default, if a required grid template is in the database, 
Feature Extraction automatically associates the appropriate grid template 
to the extraction sets when you add Agilent TIFF images to the project. If 
the grid template is not in the database, but you selected to use the 
eArray server during extraction, the Feature Extraction software tries to 
locate the correct grid template in the eArray server and use it for the 
extraction.

You can also assign a grid template or grid file to the Agilent image.

To assign a grid template for Agilent images:

1 Expand the extraction set.

2 Select a grid template from the Grid Template Browser, hold down the 
mouse button and drag it to the second position of the extraction set in 
Project Explorer. 

3 Let go of the mouse button to drop it at this position.

To assign a grid file for Agilent images:

1 Right- click the second position of the expanded extraction set and click 
Select Grid File.

2 Select the grid file, and click Open.

The grid file name appears in the extraction set, along with the grid 
template on which it is based.

Non-Agilent images Assign a grid file to non- Agilent images in the project. 
The extraction automation feature is not supported for non- Agilent 
images. Feature Extraction does not extract non- Agilent images that are 
missing grid files or protocols.
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To assign a grid file for non- Agilent images:

1 Right- click the second position of the expanded extraction set and click 
Select Grid File.

2 Select the grid file, and click Open.

AMADID is the 

Agilent MicroArray 

Design IDentifier.

Agilent microarray images scanned with an Agilent scanner For Agilent 
microarray images with barcode information included in the image, the 
software selects a grid template from the database using the AMADID 
portion of the barcode associated with the image file. If there are grid 
templates for that AMADID that come from multiple design files, the 
software selects the grid template from the most recent Agilent design file. 
To add a barcode if the image has none, see the Feature Extraction 12.2 
User Guide. 

For this automated assignment to work, make sure that the grid template 
is in the database. If it is not, you can let the Feature Extraction try to 
download the required grid template automatically from the eArray server. 
Or, you can interactively associate a grid template or grid file with the 
extraction set. See page 19 for details on how to assign a grid template or 
grid file.

Agilent uses barcode information for many workflow automation and data 
tracking steps. Inclusion of the Agilent barcode information in the TIFF 
file helps ensure that the data is quickly, easily and accurately processed 
and that informatics programs know how to analyze the results.

Agilent microarray images scanned with a non-Agilent scanner For Agilent 
microarray images generated on Roche NimbleGen MS 200 scanners, 
Molecular Devices GenePix scanners, select Innopsys InnoScan scanners, 
or select Tecan scanners, the program selects a grid template using the 
same method described above for Agilent microarray images scanned with 
an Agilent scanner. 

Non-Agilent images scanned with an Agilent scanner Non- Agilent image files 
from an Agilent scanner do not point to grid information that the Agilent 
Feature Extraction software can read. Therefore, when you load the 
non- Agilent image file, add a grid file that you have already created. 

See Chapter 3 in the Feature Extraction 12.2 User Guide to learn how to 
create grid files.
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Step 5. Assign a protocol to the extraction set (optional)

Automatically assigned protocols come from two sources: a default 
protocol associated with the grid template, or a project level default 
protocol. You select which of these options has the higher priority. (See 
Chapter 2 of the Feature Extraction 12.2 User Guide to learn how to 
associate a protocol with a grid template and where to enter the project 
level default protocol.) You can also add a protocol to the extraction set 
manually.

To add a protocol manually:

1 From the Protocol Browser select a protocol, hold down the mouse 
button and drag it to the third position of the extraction set.

2 Release the mouse button to drop the protocol onto the third position 
of the set.

Feature Extraction can run analyses on Agilent 1- color gene expression 
(GE1), 2- color gene expression (GE2), CGH, CGH+SNP, ChIP, miRNA, and 
non- Agilent 2- color GE (GE2- nonAT) microarray images scanned on the 
Agilent scanner. Agilent includes Feature Extraction protocols for 
extracting each of these image types. 

Step 6. Add or change grid templates from design files (optional)

For the Agilent images you intend to extract, you add grid templates 
based on the images’ design files to the Grid Template Browser.

1 Right- click the Grid Template Browser pane, and click Add.

2 Select a design file or files, and click Open.

Every extraction needs an image file, assigned grid template/grid file, and 
protocol. Grid templates and protocols for Agilent images are loaded to 
the extraction set automatically by the software, if the grid template is 
available in the database. If a grid template is in the database, it is 

CAUTION These Feature Extraction Protocols were optimized using data from Agilent catalog 

arrays, which have many replicated probes and validated Negative Control probes. If 

you use custom arrays without enough replicated probes, or arrays with custom probes 

designated as Negative Control probes, the default Feature Extraction Protocols may 

not be optimal. The Feature Extraction Protocol optimization also uses the Agilent 

default lab protocols for label, hybridization, wash, and scanner procedures.
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displayed automatically in the Grid Template Browser. If a grid is not in 
the database, the software automatically gets the grid template from 
eArray when the extraction starts. For details on how to update or add 
grid templates using Agilent eArray, see the Feature Extraction 12.2 User 
Guide. 

Step 7. Change QC metric set associated with the protocol to monitor QC metrics 

Occasionally, the Feature Extraction software is used in a production 
environment, where the microarray processing protocols are similar and 
monitoring run- to- run consistency is an important goal. Feature 
Extraction can help monitor this consistency with the QC metric sets. 

In earlier versions of Feature Extraction, you choose one QC metric set in 
the Project Properties tab that was used for all extractions in a project.

In version 10.5 and higher, the QC metric sets and protocols are linked. 
The Feature Extraction protocol defines which metric set is used with it. 

To change the QC metric set associated to the Feature Extraction protocol:

1 In the FE Protocol Browser, double- click a protocol to open the FE 
Protocol Editor.

2 Select Protocol Properties to see the protocol properties.

3 Under General, click the cell next to Metricset.

4 Click the down arrow, and select the QC metric set appropriate for your 
microarray application.

If a metric set you want to use is not available in the metric set list, 
import it to the database first. 

To import a QC metric set into the database:

1 Select View > QC Metric Set Browser from the Feature Extraction 
main window, if it is not already visible.

2 The QC Metric Set Browser displays all of the default metric sets and 
custom metric sets in the database. Custom metric sets are created 
using the QC Chart Tool software. Right- click in the QC Metric Set 
Browser and select Import to import metric sets that are not in the 
database.

The default QC metric sets installed with the Feature Extraction 
software are read- only and cannot be removed from the database. 
However, you can remove or change a QC metric set associated with the 
protocol and then save it as a new protocol with a different name. 
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To remove a QC metric set from the protocol:

• Select <Set empty> from the metric set list in the Protocol 
Properties.

5 Click Save As to save the new protocol.

QC metric sets Metric sets are loaded into the database when you install 
the Feature Extraction software. If you set up the eArray login as 
discussed in the section “To set up eArray login” on page 8, then Feature 
Extraction automatically downloads and installs the latest QC metric sets 
from the eArray server. 

If you remove a QC metric set, updates of QC metric sets are also 
available at www.agilent.com/chem/feqcmetrics, if you want to download 
and install them manually in Feature Extraction. 

When you create a QC metric set using the Agilent QC Chart Tool 
software, you can associate it to a protocol in Feature Extraction. When a 
project with that protocol is run, the Feature Extraction software 
summarizes the metric statistics on the QC report and shows how the 
results compare to the thresholds (if any) defined in the metric set. It also 
reports this information in the output files in the statistics table. For 
more information on using the QC Chart Tool software, see the Agilent QC 
Tools User Guide.

Step 8. Save the project 

1 Select File > Save As.

By default, your projects are saved in the folder 
C:\ProgramData\Agilent\FeatureExtractionStandalone\FEProjects

CAUTION Agilent-supplied QC metric sets are intended to assist users in monitoring microarray 

processing issues. They were not developed to detect microarray manufacturing 

issues. 

The metrics and thresholds were developed with data generated from Agilent arrays 

and using Agilent web-lab protocols, scanners, and default Feature Extraction 

protocols. Any deviation from this workflow may produce data that cannot be 

accurately quality controlled by the Agilent QC metrics and thresholds.
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General instructions
2 To save in a different location, go to or create the folder for your 
projects.

3 Type a project name, and click Save.

Step 9. Run Feature Extraction

1 Click the Project Run mode On/Off button on the Feature Extraction 
Project toolbar,  or select Project > Start Extracting. 
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Setting up an On-Time Project to Extract Agilent Image Files in Real Time
Setting up an On-Time Project to Extract Agilent Image Files in Real Time

Instructional overview
An On- Time project lets you set up the Feature Extraction software to 
extract Agilent microarray image files automatically as they are 
transferred from the Agilent scanner to a designated folder. 

Follow the workflow here and the instructions on the next pages to get 
started.

Start 
Here!

Set up and 
run Agilent 
files in 
real-time

Set the results 
path and formats

Create an 
“On-Time” 
project

Set the 
incoming 
image path

Set the Feature 
Extraction 
termination 
criteria

Set other 
properties and 
save the project

Run Feature 
Extraction

NOTE
 On-Time projects work only with Agilent microarrays scanned on the Agilent scanner.
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General Instructions

These instructions help you set up the software to run a batch of Agilent 
microarray images in real time as they arrive from the Agilent scanner to 
a folder of your choosing. These instructions do not include running 
Feature Extraction.

Step 1. Create an on-time project

• Select File > New > On- Time Project.

Note that you do not add extraction sets to on- time projects.

Figure 7 On-Time Project Properties window

Step 2. Enter the incoming image path

1 Click the cell next to Incoming Image Folder, and select the path for 
your scanned images.

2 Click OK.
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The software assigns the appropriate grid template to each of the 
Agilent microarrays and the appropriate protocol included in the Grid 
Template Properties sheet.

If you want the On- Time project to process microarrays whose grid 
templates are missing from the database, set up the software to use the 
eArray server during extraction. The required grid templates, protocols, 
and QC metric sets are automatically downloaded and installed in the 
database. See “To set up eArray login” on page 8 for more details.

Step 3. Enter termination criteria

1 Click the cell next to Use Run Duration Time Out, and select True.

2 If not expanded, expand the Duration Time folder.

3 Use the sliders to enter 0 for Days, 2 for Hours and 30 for Minutes.

Figure 8 On-Time Project run duration
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Step 4. Change QC metric set associated with a protocol to monitor QC metrics 

To change the QC metric set associated to the Feature Extraction protocol:

1 In the FE Protocol Browser, double- click a protocol to open the FE 
Protocol Editor.

2 Select the Protocol Properties tab to see the protocol properties.

3 Under General, click the cell next to Metricset.

4 Click the down arrow, and select the QC metric set appropriate for your 
microarray application.

If a metric set you want to use is not available in the metric set list, 
first import it to the database. 

To import a QC metric set into the database:

1 Select View > QC Metric Set Browser from Feature Extraction main 
window, if it is not already visible.

2 Right- click in the QC Metric Set Browser and select Import to import 
either Agilent metric sets or metric sets created with the QC Chart 
Tool.

The default QC metric sets installed with the Feature Extraction 
software are read- only and can not be removed from the database. But 
you can remove a QC metric set from the protocol. 

To remove a QC metric set associated with the protocol:

1 Select <Set empty> from the metric set list in the Protocol 
Properties.

5 Click Save As to save the new protocol.

Step 5. Save the project 

1 Select File > Save As.

By default, your projects are saved in 
C:\ProgramData\Agilent\FeatreExtractionStandalone\FEProjects.

2 To save in a different location, go to or create the folder for your 
projects.

3 Type a project name, and click Save.
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Step 6. Run Feature Extraction

1 Make sure that the scanner is ready.

2 Click the Project Run mode On/Off icon in the Feature Extraction 
Project Tools, or select Project > Start Extracting.

The image files are saved to the Incoming Image Folder as they 
complete scanning and are then extracted automatically.

You can display the progress of the extractions, the Summary Report, 
and the QC Report as you did for the Standard Project extractions.

The Summary Report notes how many metrics are within range for 
each extraction. The QC report for each image contains the values for 
the metrics and an evaluation of whether they were within or exceeded 
the threshold limits.
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In this book

This book contains brief 
instructions to help you get 
started with your Agilent 
Feature Extraction 12.2 
software. This book shows 
you:

• What is new for  
version 12.2

• How to set up and run 
batch extractions of 
existing Agilent and 
non- Agilent image files

• How to set up and run 
batch extractions of Agilent 
image files in real time
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